Bug 132601 - RHN update stops with error "Could not submit results to server"
RHN update stops with error "Could not submit results to server"
Status: CLOSED NOTABUG
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: up2date (Show other bugs)
3.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Adrian Likins
Fanny Augustin
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-09-14 18:46 EDT by Daniel Dreier
Modified: 2007-11-30 17:07 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-04-08 10:41:31 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Daniel Dreier 2004-09-14 18:46:10 EDT
Description of problem:
Error "Could not submit results to server" displayed while trying to
update RPMs on RHEL AS 3 system.

Version-Release number of selected component (if applicable):


How reproducible:

Steps to Reproduce:
1. Installed RedHat Enterprise Linux AS 3 (i386) Update 2
2. Using RedHat Network, selected all updates except
httpd-2.0.46-38.ent, libpng-1.2.2-25:2,  mod_ssl-2.0.46-38.ent:1,
and   	 tzdata-2004b-1.EL. I don't know whether not updating these
packages had anything to do with the problem.
3. run rhn_check as root on target machine. Update starts.
4. Update halts with:
"up2date_client.up2dateErrors.Up2dateNeedsUpdateError" error.
5. Run rhn_check again. Update continues.
6. After updating more packages, update halts with:
"Installing...
1:libgcc ########################################### [100%]
2:libgcj ########################################### [100%]
3:cpp ########################################### [100%]
4:libobjc ########################################### [100%]
5:libstdc++ ########################################### [100%]
https://xmlrpc.rhn.redhat.com/XMLRPC
Could not submit results to server <RetryServer for
xmlrpc.rhn.redhat.com/XMLRPC>
Error code: -22
Error Message:
Action 18960913 does not belong to server 1004911997
Error Class Code: 22
Error Class Info: Unable to retrieve requested entry.
Explanation:
An error has occurred while processing your request. If this problem
persists please enter a bug report at bugzilla.redhat.com.
If you choose to submit the bug report, please be sure to include
details of what you were trying to do when this error occurred and
details on how to reproduce this problem."

  
Actual results:


Expected results:


Additional info:
This error occured using the RHN account called verinform, on the
system called Ringo.
Comment 1 Suzanne Hillman 2004-09-15 14:36:02 EDT
The "up2date_client.up2dateErrors.Up2dateNeedsUpdateError" error looks
like it might have an up2date update which needs to happen. 

If run 'up2date' (with or without X), what does it do?
Comment 2 Suzanne Hillman 2005-04-08 10:41:31 EDT
Closing due to lack of reply in many months.

Note You need to log in before you can comment on or make changes to this bug.