Bug 132625 - Edit a printer using an imported ppd-file causes traceback
Edit a printer using an imported ppd-file causes traceback
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: foomatic (Show other bugs)
2
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Tim Waugh
:
: 140733 142698 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-09-15 04:09 EDT by Mirko Streckenbach
Modified: 2007-11-30 17:10 EST (History)
2 users (show)

See Also:
Fixed In Version: 3.0.2-8
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-11-24 05:57:27 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Mirko Streckenbach 2004-09-15 04:09:28 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.2)
Gecko/20040803

Description of problem:
If a printer is created using a privously imported PPD file, 
selecting "Edit" from the context menu in the printer list causes
a traceback and hangs the application.

Couldn't load driver information.Traceback (most recent call last):
  File "/usr/share/printconf/util/queueTree.py", line 599, in
edit_button_clicked
    if self.editQueue.editQueueDialog (iter):
  File "/usr/share/printconf/util/editQueue.py", line 414, in
editQueueDialog
    self.write_driver_options ()
  File "/usr/share/printconf/util/editQueue.py", line 919, in
write_driver_options
    for option_tuple in option_list:
TypeError: iteration over non-sequence


Version-Release number of selected component (if applicable):
system-config-printer-0.6.98-1

How reproducible:
Always

Steps to Reproduce:
1. Import the PPD from
http://www.linuxprinting.org/download/PPD/HP/mono_laser/HP_LaserJet_8100_Series.ppd
2. Create a new printer using the imported PPD as driver
3. Select "Edit" from context menu in printer list
    

Actual Results:  Traceback

Expected Results:  A window with editable options should pop up


Additional info:

Couldn't load driver information.Traceback (most recent call last):
  File "/usr/share/printconf/util/queueTree.py", line 599, in
edit_button_clicked
    if self.editQueue.editQueueDialog (iter):
  File "/usr/share/printconf/util/editQueue.py", line 414, in
editQueueDialog
    self.write_driver_options ()
  File "/usr/share/printconf/util/editQueue.py", line 919, in
write_driver_options
    for option_tuple in option_list:
TypeError: iteration over non-sequence
Comment 1 Tim Waugh 2004-11-23 14:31:26 EST
This is to do with the PPD file being encoded in ISO-8859-1, while foomatic
expects UTF-8.  The foomatic bits should handle this better.  Working on a fix.
Comment 2 Tim Waugh 2004-11-24 05:57:27 EST
The xml_esc function in PPD.pm now ensures that CDATA bytes do not have the high
bit set, and so cannot be invalid UTF-8.

Fixed in foomatic-3.0.2-8.
Comment 3 Tim Waugh 2004-12-10 10:09:19 EST
*** Bug 140733 has been marked as a duplicate of this bug. ***
Comment 6 Tim Waugh 2004-12-13 10:48:20 EST
*** Bug 142698 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.