Bug 132640 - Installer stops after transferring netstg2.img
Summary: Installer stops after transferring netstg2.img
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
(Show other bugs)
Version: 2
Hardware: i586 Linux
medium
low
Target Milestone: ---
Assignee: Jeremy Katz
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2004-09-15 12:54 UTC by Fané Henry
Modified: 2007-11-30 22:10 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-09-15 18:48:24 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Fané Henry 2004-09-15 12:54:29 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7)
Gecko/20040615 Firefox/0.9

Description of problem:
In order to upgrade a machine to FC2 with an adaptec 7892 SCSI
controller I decided to create my own install bootdisk. It works fine
(ie. detects devices), but when the netstg2.img is downloaded I get
the following messages:
...
*transfering ftp://my_ftpserv/Fedora/2/RedHat/base/netstg2.img to a fd
*copied 18411520 bytes to /tmp/ramfs/netstg2.img (complete)
*mntloop loop0 on /mnt/runtime as /tmp/ramfs/netstg2.img fd is 21
*failed to mount loop: No such device
*Error mounting /dev/loop0 on /mnt/runtime (No such device)

On the other log file, I get:
...
<7> ISO 9660 Extensions: RRIP_1991A
<4> Unable to identify CD-ROM format.
<4> VFS: Can't find ext2 filesystem on dev loop0.

I made the bootdisk as follow:
*get the diskboot.img from fedora 2 install CD,
*add 2.6.8 modules to initrd (cpio archive modules.cgz),
*add kernel 2.6.8 to diskboot.img
*burn as bootable CD.


Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. burn the CD with new diskboot.img
2. boot on CD
3. choose ftp install
    

Expected Results:  Continue install after downloading netstg2.img


Additional info:

Comment 1 Jeremy Katz 2004-09-15 18:48:24 UTC
You don't have all of the modules you need (ie, your boot disk is
malformed)

Comment 2 Fané Henry 2004-09-16 04:04:42 UTC
Thanks for your reply, I took all modules from 2.6.8.1-521 kernel with :

find /lib/modules/2.6.8.1-521/kernel/drivers -name *.ko | cpio -o -H
crc > modules

So you are right because I don't took modules from
/lib/modules/2.6.8.1-521/kernel

I will try.


Note You need to log in before you can comment on or make changes to this bug.