Bug 132676 - redundant memmove ?
redundant memmove ?
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: kdenetwork (Show other bugs)
3
All Linux
medium Severity medium
: ---
: ---
Assigned To: Ngo Than
Ben Levenson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-09-15 14:57 EDT by d.binderman
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-09-16 08:19:27 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description d.binderman 2004-09-15 14:57:07 EDT
Description of problem:


I just tried to compile package kdenetwork-3.2.2-1 from
Redhat Fedora Core 3 Test 1.

The compiler said

servercontroller.cpp:542: warning: statement has no effect

The source code is

    memmove(new_s, new_s, strlen(new_s)); // See above for strlen()

Copy a bunch of bytes from one place to the same place doesn't
have much point. Suggest delete code.


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Ngo Than 2004-09-16 08:19:27 EDT
It looks like a cut and paste bug. it's fixed in kdenetwork-3.3.0-2.
Thanks for your report.

Note You need to log in before you can comment on or make changes to this bug.