Bug 13272 - Missing /usr/include files after upgrade
Missing /usr/include files after upgrade
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: kernel (Show other bugs)
6.1
i586 Linux
medium Severity medium
: ---
: ---
Assigned To: Michael K. Johnson
:
: 13291 14337 17282 17658 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-06-30 09:40 EDT by alan.thew
Modified: 2008-05-01 11:37 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-09-23 18:28:28 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description alan.thew 2000-06-30 09:40:29 EDT
After upgrading to the header files for kernel 2.2.16-3
I found that /usr/include/linux and /usr/include/asm
were missing. I have put them back myself but this has never
happened before and I started with RH 4.1 and have upgraded
the kerenl + headers many times.
Comment 1 Alan Cox 2000-09-16 18:12:56 EDT
*** Bug 13291 has been marked as a duplicate of this bug. ***
Comment 2 Alan Cox 2000-09-16 18:15:14 EDT
*** Bug 14337 has been marked as a duplicate of this bug. ***
Comment 3 Alan Cox 2000-09-16 18:16:40 EDT
*** Bug 17282 has been marked as a duplicate of this bug. ***
Comment 4 Alan Cox 2000-09-23 18:28:26 EDT
*** Bug 17658 has been marked as a duplicate of this bug. ***
Comment 5 Doug Ledford 2000-10-26 16:51:08 EDT
Due to a bug in the kernel-headers %post script, you need to re-install the
kernel headers package to get the headers there properly.  Once the rpm is
installed once, then doing a forced install (not an upgrade) is what solves the
problem:

rpm -ivh --force kernel-headers-2.2.16-3.i386.rpm

should work for you.

Note You need to log in before you can comment on or make changes to this bug.