Bug 132733 - i386 package in rhel-ia64-as-3 channel
i386 package in rhel-ia64-as-3 channel
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: up2date (Show other bugs)
3.0
ia64 Linux
medium Severity medium
: ---
: ---
Assigned To: Bret McMillan
Fanny Augustin
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-09-16 10:28 EDT by Tomas Edwardsson
Modified: 2007-11-30 17:07 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-10-19 15:18:31 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Tomas Edwardsson 2004-09-16 10:28:54 EDT
[root@ia64 root]# up2date compat-db

Fetching Obsoletes list for channel: rhel-ia64-as-3...

Fetching rpm headers...
########################################

Name                                    Version        Rel     
----------------------------------------------------------
compat-db                               4.0.14         5             
   i386  
compat-db                               4.0.14         5             
   ia64  

Testing package set / solving RPM inter-dependencies...
Traceback (most recent call last):
  File "/usr/sbin/up2date", line 1174, in ?
    sys.exit(main() or 0)
  File "/usr/sbin/up2date", line 772, in main
    fullUpdate, dryRun=options.dry_run))
  File "/usr/sbin/up2date", line 1066, in batchRun
    batch.run()
  File "up2dateBatch.py", line 74, in run
  File "up2dateBatch.py", line 159, in __dryRun
  File "up2date.py", line 398, in dryRun
  File "depSolver.py", line 728, in solvedep
  File "depSolver.py", line 695, in process_deps
  File "depSolver.py", line 536, in __dependencies
  File "depSolver.py", line 390, in __add
  File "headers.py", line 37, in __getitem__
  File "headers.py", line 42, in __retrievePackage
  File "rpcServer.py", line 304, in doCall
  File "repoDirector.py", line 30, in getHeader
IndexError: list index out of range
Comment 1 Suzanne Hillman 2004-09-16 15:09:16 EDT
What version of compat-db did you have on your system when you tried
to up2date it?
Comment 2 Tomas Edwardsson 2004-09-17 06:39:07 EDT
None, was trying a new install.
Comment 3 Suzanne Hillman 2004-10-01 13:21:43 EDT
If you do a 'rpm -q compat-db', do you show both the i386 and the ia64
versions already on your system?
Comment 4 Tomas Edwardsson 2004-11-16 18:47:18 EST
If I do that now it will show i386 version on the system. But as I
mentioned earlier, compat-db was not installed on the system on the
time I used "up2date compat-db". I was installing a package which was
not present before.
Comment 5 Tomas Edwardsson 2004-11-16 18:49:03 EST
Uhm, actually I misspoke.

If I do "rpm -q compat-db" it will now show the ia64 version because I
gave up on "up2date compat-db" to install the package and found it on
my rhel CD.

Comment 6 RHEL Product and Program Management 2007-10-19 15:18:31 EDT
This bug is filed against RHEL 3, which is in maintenance phase.
During the maintenance phase, only security errata and select mission
critical bug fixes will be released for enterprise products. Since
this bug does not meet that criteria, it is now being closed.
 
For more information of the RHEL errata support policy, please visit:
http://www.redhat.com/security/updates/errata/
 
If you feel this bug is indeed mission critical, please contact your
support representative. You may be asked to provide detailed
information on how this bug is affecting you.

Note You need to log in before you can comment on or make changes to this bug.