Bug 132734 - the component fails to remove installed packages with a "packages not found" error
the component fails to remove installed packages with a "packages not found" ...
Status: CLOSED NOTABUG
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: redhat-config-packages (Show other bugs)
3.0
i686 Linux
medium Severity high
: ---
: ---
Assigned To: Jeremy Katz
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-09-16 10:31 EDT by S.P.T.Krishnan
Modified: 2007-11-30 17:07 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-09-21 16:32:51 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description S.P.T.Krishnan 2004-09-16 10:31:45 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 6.0; X11; Linux i686) Opera 
7.51  [en]

Description of problem:
I did a everything-install of the RHEL3 system.
Now I want to remove some packages.

When I use the redhat-config-packages to do this, for all the 
packages I tried for, the installer gives the same error and aborts !

The error is "Packages not found" and a list of packages appears.
This list is different for different package uninstall.

In addition, the terminal from where this program was started also 
spits out error messages...

How can this happen ?
I installed the system using everything-install method, so the 
packages have to be there.



Version-Release number of selected component (if applicable):
redhat-config-packages-1.2.9.2-1

How reproducible:
Always

Steps to Reproduce:
1. Start with a RHEL3 installation done with everything-install.
2. Start redhat-config-packages 
3. uncheck a package-group, like postgresql and click update.
4. An error message throws up...
    

Actual Results:  fails to remove packages with error messages 
"Packages not found"

Expected Results:  remove the packages

Additional info:

=====
ERRORS PUMPED INTO THE TERMINAL FROM WHERE redhat-config-packages was 
started from
I was trying to uninstall postgresql
=====

* dialup references package statserial which doesn't exist
* dialup references package lrzsz which doesn't exist
* setting KDE to not installed
* base references package openCryptoki which doesn't exist
* base references package acpid which doesn't exist
* authd-0:1.4.1-1.rhel3.i386 not installed in group Base
* diskdumputils-0:0.4.0-1.i386 not installed in group Base
* base references package prctl which doesn't exist
* base references package iscsi which doesn't exist
* base references package reiserfs-utils which doesn't exist
* base references package sendmail-docs which doesn't exist
* kernel-source-0:2.4.21-20.EL.i386 not installed in group Kernel 
Development
* setting GNOME to not installed
* system-tools references package rhnmd which doesn't exist
* finger-server-0:0.17-18.i386 not installed in group Network Servers
* legacy-software-development references package compat-gcc-legacy 
which doesn't exist
* development-libs references package gnu-efi which doesn't exist
* graphical-internet references package mozilla-psm which doesn't 
exist
* legacy-software-support references package nss_db_compat which 
doesn't exist
* compat-arch-development references package strace64 which doesn't 
exist
* core references package yaboot which doesn't exist
* core references package iprutils which doesn't exist
* core references package efibootmgr which doesn't exist
* core references package elilo which doesn't exist
* core references package s390utils which doesn't exist
* core references package ppc64-utils which doesn't exist
* setting Workstation Common to not installed
* setting Server to not installed
* development-tools references package gcc-ppc32 which doesn't exist
* development-tools references package libunwind which doesn't exist
* development-tools references package gcc-c++-ppc32 which doesn't 
exist
* compat-arch-support references package openCryptoki which doesn't 
exist
Unselecting already uninstalled package qt-ODBC
('libodbc.so.1', None)
('libodbcinst.so.1', None)
('libodbcpsql.so.2', None)
('unixODBC', None)
('unixODBC', '2.2.8')
('rh-postgresql-jdbc', '7.3.4')
('rh-postgresql-jdbc', '7.3.4')
Comment 1 Suzanne Hillman 2004-09-16 15:08:13 EDT
This looks like something for which you might be best off contacting
support. With your valid entitlement, either go to
http://www.redhat.com/support, or call 800-REDHAT1

Note You need to log in before you can comment on or make changes to this bug.