Bug 132762 - rhn, up2date discrepancy
Summary: rhn, up2date discrepancy
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: crash (Show other bugs)
(Show other bugs)
Version: 3.0
Hardware: x86_64 Linux
medium
medium
Target Milestone: ---
Assignee: Dave Anderson
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2004-09-16 19:18 UTC by Andrew Sydelko
Modified: 2007-11-30 22:07 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-10-19 19:18:28 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Andrew Sydelko 2004-09-16 19:18:00 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.2)
Gecko/20040820 Galeon/1.3.17 (Debian package 1.3.17-1)

Description of problem:
Through the rhn.redhat.com web interface, crash shows up as a package
that needs to be updated (3.7-5 -> 3.8-3). But running 'up2date -u' on
the system shows nothing to be upgraded. If you try to run 'up2date
crash' it claims the package is up to date.

Something is confused...

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. install RHEL 3.0 update 3
2. see rhn.redhat.com say there is a new crash package
3. try to update the crash package
    

Additional info:

Comment 1 Jay Fenlason 2004-09-17 16:17:18 UTC
My disk3 of RHEL3-U3 has crash-3.8-3 on it.  What does "rpm -q crash 
report? 

Comment 2 Andrew Sydelko 2004-09-17 16:19:51 UTC
I apologize, I installed update 2, and now am trying to get the
latest packages. rpm -q crash shows 3.7-5.

Comment 3 Dave Anderson 2004-09-17 19:11:55 UTC
I'm the author and maintainer of the crash utility, but have
absolutely nothing to do with installation issues.  All I can
tell you is that 3.7-5 came out with the initial version of 
RHEL3, but it did not support x86_64.  In RHEL3-U3, crash 3.8-3
introduced x86_64 support.  So there shouldn't have even been
an x86_64 crash utility with any RHEL3 x86_64 kernel before U3.

Comment 4 Andrew Sydelko 2004-09-17 19:15:04 UTC
Ok, I guess the problem is that I have the i386 version installed and
so up2date wants to upgrade it, but since the architectures are
different it can't... 

I bet if I remove the package and then reinstall it, it will be fine. 

...

Yep. Removing the installed crash, and then running up2date crash
seems to have worked. I think up2date needs better bi-arch support...
(Maybe this should be a bug for up2date).

Comment 5 Dave Anderson 2004-09-17 20:07:03 UTC
Right -- there's nothing I can do (at least that I know about...)

Comment 6 RHEL Product and Program Management 2007-10-19 19:18:28 UTC
This bug is filed against RHEL 3, which is in maintenance phase.
During the maintenance phase, only security errata and select mission
critical bug fixes will be released for enterprise products. Since
this bug does not meet that criteria, it is now being closed.
 
For more information of the RHEL errata support policy, please visit:
http://www.redhat.com/security/updates/errata/
 
If you feel this bug is indeed mission critical, please contact your
support representative. You may be asked to provide detailed
information on how this bug is affecting you.


Note You need to log in before you can comment on or make changes to this bug.