Bug 132785 - up2date dies while loading package headers
up2date dies while loading package headers
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: up2date (Show other bugs)
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Bret McMillan
Fanny Augustin
Depends On:
  Show dependency treegraph
Reported: 2004-09-16 21:07 EDT by Doug Knight
Modified: 2007-11-30 17:07 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2007-10-19 15:18:22 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Doug Knight 2004-09-16 21:07:30 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7)
Gecko/20040626 Firefox/0.9.1

Description of problem:
One of the package headers in /var/spool/up2date got cut short
(probably network failure).  up2date would silently die while trying
to load the package headers afterward.  Running up2date --nox
<package> would result in a message box being displayed saying
"Unknown Error" (the message box being displayed while the --nox flag
is not the bug being addressed here).  Turning on debugging and
verbose output revealed that it was stopping after reading a small
number of headers.  Re/moving the headers will force them to be
redownloaded and works around the problem.

up2date should at least state that it failed to load a package header
from the disk, and which header it was trying to load.  It would be
better, though if it tried to re-download a file that couldn't be
loaded properly and only give a warning message if the download failed
then tried to continue on, ignoring the damaged package.

Version-Release number of selected component (if applicable):

How reproducible:

Steps to Reproduce:
1. mv /var/spool/up2date/XFree86-Xvfb-4.3.0-68.EL.i386.hdr
2. head -c 123244
3. up2date

Actual Results:  up2date would die while trying to read the package

Expected Results:  up2date would try to work around the damaged
package header, and would not crash.

Additional info:
Comment 2 RHEL Product and Program Management 2007-10-19 15:18:22 EDT
This bug is filed against RHEL 3, which is in maintenance phase.
During the maintenance phase, only security errata and select mission
critical bug fixes will be released for enterprise products. Since
this bug does not meet that criteria, it is now being closed.
For more information of the RHEL errata support policy, please visit:
If you feel this bug is indeed mission critical, please contact your
support representative. You may be asked to provide detailed
information on how this bug is affecting you.

Note You need to log in before you can comment on or make changes to this bug.