Bug 132791 - Cannot set cards to correct locations
Cannot set cards to correct locations
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: system-config-display (Show other bugs)
3
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Paul Nasrat
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-09-16 23:30 EDT by Jim Cornette
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-10-19 04:13:32 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
This is xorg.conf from attempt to setup cards monitors (3.41 KB, text/plain)
2004-09-16 23:42 EDT, Jim Cornette
no flags Details
i810 primary - radeon secondary (37.88 KB, text/plain)
2004-09-23 20:43 EDT, Jim Cornette
no flags Details
this is the i810 master - radeon secondary configuration via r-c-display (3.29 KB, text/plain)
2004-09-23 20:47 EDT, Jim Cornette
no flags Details
this shows the i810 -vesa lockup (74.92 KB, text/plain)
2004-09-23 20:54 EDT, Jim Cornette
no flags Details
this is /var/log/messages after testing (567.31 KB, text/plain)
2004-09-23 21:00 EDT, Jim Cornette
no flags Details
lspci -vvv (4.41 KB, text/plain)
2004-09-23 21:17 EDT, Jim Cornette
no flags Details
This is with 815 as primary Xorg.0.log (15.65 KB, text/plain)
2004-09-28 22:52 EDT, Jim Cornette
no flags Details
xorg.conf resulting from s-c-display (3.32 KB, text/plain)
2004-09-28 22:55 EDT, Jim Cornette
no flags Details

  None (edit)
Description Jim Cornette 2004-09-16 23:30:08 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.2)
Gecko/20040809

Description of problem:
I tried to setup two video cards. The first video card is part of the
motherboard and is an 815 Graphics controller. The second card is a
radeon 7200.
The situation is that the radeon card causes lockups, so BIOS settings
are set for the internal 815 card to be the primary graphics controller.
The problem, the s-c-d tool will not save my information provided and
always shows some backwards configuration. If the tool is ran again,
all my settings are lost. The primary card is the radeon through the
tool. The 815 is the secondary.
Since the BIOS settings are honored and the 815 is my primary video
interface, the tool thinks that I have my main display on the
secondary, but it is on the primary, which is not the secondary.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Set BIOS to have internal card as main video, not the pci video card 
2. Boot into FC3T2 RC2
3.  start X
4. Try to run s-c-d to enable dual-head display
5. adjust settings 
6. save and exit
7. restart X
8. notice settings not as desired
9. Try to adjust settings, save and exit
10. restart X
11. notice cannot set display as desired
12. close down computer, pull PCI card for awhile

    

Actual Results:  If radeon is set as primary video, X will lockup machine
server tries the radeon settings first, then finally tried the 815 card
After entering s-c-d, the settings for the monitor and card are correct.
after checking dual head, adjusted settings for secondary as radeon
video on 815 low resolution 800 x 600, radeon card had garbage, but
some artifacts of activity.
The settings were all wrong.

Expected Results:  I expected a primary card as 815 w/ 1280 x 1024
resolution, 16 depth and the radeon at 640 x 480 with 8 depth (low res
secondary monitor)


Additional info:

I have the resulting xorg.conf file to attach to the report.
Comment 1 Jim Cornette 2004-09-16 23:42:39 EDT
Created attachment 103940 [details]
This is xorg.conf from attempt to setup cards monitors
Comment 2 Jim Cornette 2004-09-23 20:43:08 EDT
Created attachment 104236 [details]
i810 primary - radeon secondary

I have two troubled cards, this is trying to set the internal Intel 815 card to
the main card and the radeon 7200 as secondary.
I'll attach the xorg.conf file for the dual boot configuration next
Comment 3 Jim Cornette 2004-09-23 20:47:44 EDT
Created attachment 104237 [details]
this is the i810 master - radeon secondary configuration via r-c-display

with this setup, I got vertical lines on the i810 driver and the radeon 7200
seened to be pulsating. There is an indicator light on the display that seemed
to be trying again and again. The lockup log for xorg is available.
Comment 4 Jim Cornette 2004-09-23 20:51:44 EDT
The previous log was substituted with the vesa driver. The radeon was
in it originally. The radeon driver caused the pulsing. With the
previous configuration, I got the vertical stripes on the display and
the lockup.
Comment 5 Jim Cornette 2004-09-23 20:54:22 EDT
Created attachment 104238 [details]
this shows the i810 -vesa lockup

This is thelog for the lockup with changing the radeon driver to vesa. The
server was a mess and the log might contain information regarding the lockup
Comment 6 Jim Cornette 2004-09-23 21:00:37 EDT
Created attachment 104239 [details]
this is /var/log/messages after testing

The trial was to setup xorg with the 815 card as primary display and the radeon
7200 card setup as secondary card. This failed with a pulsating lockup on the
radeon display. Vertical stripes were on the secondary display.
see next comments for more details.
Comment 7 Jim Cornette 2004-09-23 21:14:03 EDT
1) remove xorg.conf then try to setup the 815 as primary and radeon as
secondary. - Result: s-c-d tried radeon first, this failed, then the
815 card was tried. X started and let me configure the cards. 815
primary, radeon secondary.
I then exited X and tried the new setup. (Startx and runlevel 3). This
is when the lockup happened. (pulsing radeon, 815 had vertical
stripes. - Cure: hard reset
2) Reboot computer, edit /etc/X11/xorg.conf and change radeon to vesa
driver. Startx and get vertical stripes. - Needed to hard reset.
3) reboot computer, change both drivers to vesa, start X. - Result:
diagonal and unstable lines on the 815 display and had a blue
background. The radeon card initialized and I was able to use the
secondary display to perform tasks. After exiting X and observing the
tty screen, only half of the font was on the screen. The font was only
the top have and seemed to be trunced. The radeon display blanked out
and seemed to act correctly.
Finally, I changed the xorg.conf file to single mode instead of dual
head. My final attachment will be the output of lspci -vvv to show
hardware in this computer.
Comment 8 Jim Cornette 2004-09-23 21:17:53 EDT
Created attachment 104240 [details]
lspci -vvv

This should do it. Hopefully this info is valuable. I don't mean to flood w/
invalid information.
Thanks!

Jim
Comment 9 Paul Nasrat 2004-09-28 08:31:58 EDT
Can you test with s-c-display 1.0.20 which has a fix to prevent
reconfiguration when not in --reconfig mode.
Comment 10 Jim Cornette 2004-09-28 22:47:33 EDT
I have system-config-display-1.0.19-0.1 installed after the latest
rawhide upgrade. The problem is still here, even with single head.

I'll install the newest version when located.

What happened with the single head configuration is enclosed as an
attachment. The pci radeon is set as secondary. The 815 card started
with several tried to reconfigure the card.
Comment 11 Jim Cornette 2004-09-28 22:52:16 EDT
Created attachment 104482 [details]
This is with 815 as primary Xorg.0.log

The xorg.conf file will be attached regarding the mis-configuration done by
s-c-display. The Intel card was chosen as the primary card manually. This did
not take. It took whatever incorrect assumption was determined by the wizard.
Comment 12 Jim Cornette 2004-09-28 22:55:42 EDT
Created attachment 104483 [details]
xorg.conf resulting from s-c-display

I'll search for the version suggested and test as per request. I upgraded from
rawhide, then tested, expecting s-c-display to be newer.
Comment 13 Jim Cornette 2004-09-29 22:25:35 EDT
 When trying system-config-display-1.0.20-1 I get the below results.
The positive news is that the 815 card was not changed to a radeon for
 my promary card. 
The traceback happens when I selected dual-head, individual laptops
and chose the radeon card for the secondary. The error is generated
when I clicked on the OK, close or whatever the button states for
exiting the tool.
I have not tried to change the settings post earlier version reported
above. I plan on skipping the dual head attempts until further advice.
I will try th see if the 815 can be setup in single-head mode to test
the new X version at different resolutions.
Thanks!
Jim

Trying with card: ATI Radeon 7200
in hydrate_second
Traceback (most recent call last):
  File "/usr/share/system-config-display/xConfigDialog.py", line 125,
in ok
    lower_hsync, upper_hsync =
string.split(str(self.second_monitor_hsync), "-")ValueError: unpack
list of wrong size
Traceback (most recent call last):
  File "/usr/share/system-config-display/xConfigDialog.py", line 125,
in ok
    lower_hsync, upper_hsync =
string.split(str(self.second_monitor_hsync), "-")ValueError: unpack
list of wrong size
Comment 14 Paul Nasrat 2004-10-19 04:13:32 EDT
Closing this bug - the traceback is covered by you in:

bug #135991

Note You need to log in before you can comment on or make changes to this bug.