Bug 132861 - Missing lo entry in routing table in RHEL Update 3
Missing lo entry in routing table in RHEL Update 3
Status: CLOSED NOTABUG
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: stunnel (Show other bugs)
3.0
i686 Linux
medium Severity low
: ---
: ---
Assigned To: Miloslav Trmač
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-09-17 23:01 EDT by Ian Laurie
Modified: 2007-11-30 17:07 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-05-31 18:16:22 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ian Laurie 2004-09-17 23:01:04 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4.3)
Gecko/20040803

Description of problem:
The lo entry is missing from the routing table after update 3.  I
reported this bug against FC2 also, and was reassigned to stunnel but
I'm not convinced that is necessarily where the problem is.

Destination     Gateway         Genmask         Flags Metric Ref   
Use Iface
10.1.2.0        *               255.255.255.0   U     0      0       
0 eth0
default         router          0.0.0.0         UG    0      0       
0 eth0

This bug does not exist after a CD installation.  I'm 99% sure it
started after update 3.

Version-Release number of selected component (if applicable):
stunnel-4.04-4

How reproducible:
Always

Steps to Reproduce:
1. Install RHEL then run up2date to get to "Update 3" status.
2. Issue "route" command.
3.
    

Actual Results:  Routing table is missing the entry for "lo".

Expected Results:  I would expect a "lo" entry.

Additional info:

When I originally reported this against FC2 I used RHEL 3 as a
reference and the "lo" entry was there then.  That was about a month
ago before the update 3 set of updates. 

Now the "lo" entry is missing from RHEL 3 as well.

A commenter in the FC2 bug 129365 said that a fresh CD install of FC2
had the "lo" entry, but that it got killed running up2date and
updating.  I can't confirm that though as I only noticed the problem
after many updates had been made.

I must admit that the system seems to work fine without the entry.  I
am concerned by side effects as yet undescovered though.

In the FC2 thread Red Hat reassigned the bug to stunnel so I am
reporting against stunnel here (but stunnel has not been updated in
RHEL 3 !!).
Comment 1 Ian Laurie 2004-11-22 18:39:28 EST
Is this issue a bug?

FC2 and FC3 both have missing lo entries.  Can we assume this is
normal and expected behavior from now on?  Reclassify as "NOTABUG" ??
Comment 2 Miloslav Trmač 2005-05-31 18:16:22 EDT
$ /sbin/ip addr ls
1: lo: <LOOPBACK,UP> mtu 16436 qdisc noqueue
    link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
    inet 127.0.0.1/8 brd 127.255.255.255 scope host lo
...

127/8 is treated as a local host IP address, a routing table entry is
not necessary.

Note You need to log in before you can comment on or make changes to this bug.