Bug 132864 - possible SCSI subsystem problems with 2.6.8-1.521
possible SCSI subsystem problems with 2.6.8-1.521
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
2
i686 Linux
medium Severity high
: ---
: ---
Assigned To: Dave Jones
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-09-18 05:20 EDT by Jouni Leppajarvi
Modified: 2015-01-04 17:09 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-11-28 16:36:49 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jouni Leppajarvi 2004-09-18 05:20:48 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; rv:1.7.3) Gecko/20040914
Firefox/0.10

Description of problem:
Switching to kernel 2.6.8-1.521 from 2.6.7-1.494.2.2 (as supplied by
up2date/yum) seems to have broken two things :

1) When using an external HD over USB 2.0 for backups my laptop tends
to freeze so that I've to remove the battery (and fsck everything) to
recover. This seems to happen faster / more frequently if I try to do
something else while backing up. The 2.6.7... kernel works just fine here.

2) Using the GUI (Gnome) CD Creator doesn't work any more but CD
creation always fails (see Additional Information). Again this works
just fine with the 2.6.7... kernel.

The common denominator (or at least one of them) would seem to be that
both of the above make use of the SCSI subsystem. In the first case
the drive is presented as /dev/sda, in the second case it is my
understanding that even IDE CD(-RW) drives are presented to the
applications as SCSI drives.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
see description
    

Actual Results:  case 1) frozen computer

case 2) CD creation failed with error dialog (see Additional Information)

Expected Results:  case 1) normal operation

case 2) CD created ok

Additional info:

Reproduceability : 2) seems to be 100%, I'd rather not test 1) very
extensively but so far it has always (3 times ?) crashed if I've tried
to do other things (web browsing mostly) while my backup script is running

I got this from CD Creator (error dialog / details) :

cdrecord: Illegal write mode for this drive.
cdrecord: Drive does not support TAO recording.
SCSI buffer size: 64512
cdrecord: Warning: using inofficial libscg transport code version
(schily - Red Hat-scsi-linux-sg.c-1.80-RH '@(#)scsi-linux-sg.c 1.80
04/03/08 Copyright 1997 J. Schilling').
Linux sg driver version: 3.5.27
Warning: Open by 'devname' is unintentional and not supported.
scsibus: -2 target: -2 lun: -2
devname: '/dev/hdc'
scsidev: '/dev/hdc'
cdrecord: WARNING: This causes a high risk for buffer underruns.
cdrecord: Permission denied. WARNING: Cannot set priority using
setpriority().
cdrecord: Operation not permitted. WARNING: Cannot set RR-scheduler
cdrecord: WARNING: This causes a high risk for buffer underruns.
cdrecord: Cannot allocate memory. WARNING: Cannot do mlockall(2).
cdrecord: Continuing in 5 seconds...
cdrecord: Future versions of cdrecord may have different drive
dependent defaults.
cdrecord: Asuming -tao mode.
cdrecord: No write mode specified.
 
The PC is a PackardBell EasyNote laptop with AMD Athlon-XP-M 2400+ &
VIA Chipset (including the USB 2.0 controller), the CD drive is a 'QSI
CD-RW/DVD-ROM SBW242B, the external USB drive is a LaCie/80GB/USB 2.0
Comment 1 Dave Jones 2004-11-27 15:24:01 EST
mass update for old bugs:

Is this still a problem with the 2.6.9 based update kernel ?
Comment 2 Jouni Leppajarvi 2004-11-28 16:30:46 EST
These problems do not seem to occur with 2.6.9-1.6_FC2. Case closed (?).

 

Note You need to log in before you can comment on or make changes to this bug.