Bug 132880 - gimp crashes with segmentation fault on startup
gimp crashes with segmentation fault on startup
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: prelink (Show other bugs)
2
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Jakub Jelinek
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-09-18 13:47 EDT by Mark Richters
Modified: 2007-11-30 17:10 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-10-04 08:25:23 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
result of "rpm -qa|sort" (16.85 KB, text/plain)
2004-09-18 15:28 EDT, Mark Richters
no flags Details

  None (edit)
Description Mark Richters 2004-09-18 13:47:49 EDT
Description of problem:
10008:$ gimp 
Segmentation fault
10009:$ gimp --verbose
INIT: gimp_load_config
Parsing '/etc/gimp/2.0/gimprc'
Parsing '/home/mr/.gimp-2.0/gimprc'
gimp_composite: use=yes, verbose=no
Processor instruction sets: +mmx +sse -sse2 -3dnow -altivec -vis
Adding theme 'Default' (/usr/share/gimp/2.0/themes/Default)
Adding theme 'Small' (/usr/share/gimp/2.0/themes/Small)
Writing '/home/mr/.gimp-2.0/themerc'
INIT: gimp_initialize
INIT: gimp_real_initialize
INIT: gui_initialize_after_callback
INIT: gimp_restore
Segmentation fault


Version-Release number of selected component (if applicable):
gimp-2.0.4-0.fc2.1

How reproducible:
Always

Steps to Reproduce:
See description


Additional info:

I'm not sure whether this is helpful but this is the stacktrace:

(gdb) bt
#0  0x0069c640 in ?? ()
#1  0x0068c750 in gimp_module_db_load () from
/usr/lib/libgimpmodule-2.0.so.0
#2  0x0818e54e in gimp_modules_load ()
#3  0x0818b34f in gimp_restore ()
#4  0x08084ac2 in app_run ()
#5  0x0808518a in main ()
Comment 1 Nils Philippsen 2004-09-18 14:03:30 EDT
This does not happen here ;-), to find out why you have problems,
please attach the list of installed packages ("rpm -qa | sort") and
redo the backtrace with the debuginfo package
(http://download.fedora.redhat.com/pub/fedora/linux/core/updates/2/i386/debug/gimp-debuginfo-2.0.4-0.fc2.1.i386.rpm)
installed. Thanks.
Comment 2 Mark Richters 2004-09-18 15:28:33 EDT
Created attachment 103989 [details]
result of "rpm -qa|sort"
Comment 3 Mark Richters 2004-09-18 15:33:59 EDT
Here's the backtrace, now with debuginfo. The directory
/home/mr/.gimp-2.0/modules exists and is empty. When I delete the
~/.gimp-2.0 tree the user installation runs as usual but then it 
crashes with the same trace.

(gdb) run -s
Starting program: /usr/bin/gimp -s
[Thread debugging using libthread_db enabled]
[New Thread -151105408 (LWP 10794)]

Program received signal SIGSEGV, Segmentation fault.
[Switching to Thread -151105408 (LWP 10794)]
0x0069c640 in ?? ()
(gdb) bt
#0  0x0069c640 in ?? ()
#1  0x0068c750 in gimp_module_db_load (db=0x9b51390, 
    module_path=0xa0e1918
"/home/mr/.gimp-2.0/modules:/usr/lib/gimp/2.0/modules")
    at gimpmoduledb.c:308
#2  0x0818e54e in gimp_modules_load (gimp=0x9b50f38) at gimp-modules.c:147
#3  0x0818b34f in gimp_restore (gimp=0x9b50f38, 
    status_callback=0x8084d90 <app_init_update_none>) at gimp.c:911
#4  0x08084ac2 in app_run (full_prog_name=0x10 <Address 0x10 out of
bounds>, 
    gimp_argc=1, gimp_argv=0xfefb6cb8, alternate_system_gimprc=0x0, 
    alternate_gimprc=0x9b56b28 "", session_name=0x10 <Address 0x10 out
of bounds>, 
    batch_cmds=0x10, no_interface=0, no_data=16, no_fonts=16,
no_splash=16, 
    be_verbose=1, use_shm=16, use_cpu_accel=6316020, console_messages=16, 
    stack_trace_mode=16, pdb_compat_mode=16) at app_procs.c:222
#5  0x0808518a in main (argc=2, argv=0xfefb6cb4) at main.c:477
Comment 4 Ken Barber 2004-09-18 16:18:35 EDT
Same thing started happening here after I let up2date update my
version of gtk last night.

I rely on The Gimp to get my work done; if I can't get this fixed by
Monday I'm going to have to install another distro.

Any diags you want, please let me know.  You might have to step me
through the process of getting them.

Ken Barber
Comment 5 Nils Philippsen 2004-09-18 17:43:15 EDT
Funny that you mention upgrading your gtk, because this version of the
gimp has been out for a while. You might want to downgrade gtk2 (e.a.)
to previous versions. As an aid, here are my versions of gimp and its
dependencies, please compare if you see any differences:

nils@gibraltar:~> rpm -q atk fontconfig freetype GConf2 gimp
gimp-data-extras gimp-print gimp-print-plugin glib2 glibc gtk2
gtkhtml2 libart_lgpl libbonobo libbonoboui libcroco libjpeg libpng
librsvg2 libtiff libxml2 pango popt xorg-x11-libs zlib
atk-1.6.0-1
fontconfig-2.2.1-10
freetype-2.1.7-4
GConf2-2.6.0-7
gimp-2.0.4-0.fc2.1
gimp-data-extras-1.2.0-11
gimp-print-4.2.6-11
gimp-print-plugin-4.2.6-11
glib2-2.4.0-1
glibc-2.3.3-27
gtk2-2.4.7-2.5
gtkhtml2-2.6.0-1
libart_lgpl-2.3.16-2.1
libbonobo-2.6.2-1
libbonoboui-2.6.0-1
libcroco-0.4.0-4
libjpeg-6b-31.1
libpng-1.2.5-8
librsvg2-2.6.4-2
libtiff-3.5.7-16.1
libxml2-2.6.9-1
pango-1.4.1-1
popt-1.9.1-0.3
xorg-x11-libs-6.7.0-8
zlib-1.2.1.1-2.1

You might also want to verify that the installed packages are intact:

root@gibraltar:~> rpm -V atk fontconfig freetype GConf2 gimp
gimp-data-extras gimp-print gimp-print-plugin glib2 glibc gtk2
gtkhtml2 libart_lgpl libbonobo libbonoboui libcroco libjpeg libpng
librsvg2 libtiff libxml2 pango popt xorg-x11-libs zlib

Comment 6 Nils Philippsen 2004-09-18 17:44:26 EDT
Forgot: please tell me whether downgrading helped you or not.
Comment 7 Ken Barber 2004-09-18 18:50:51 EDT
[root@johngalt root]# rpm -q atk fontconfig freetype GConf2 gimp
gimp-data-extras gimp-print gimp-print-plugin glib2 glibc gtk2
gtkhtml2 libart_lgpl libbonobo libbonoboui libcroco libjpeg libpng
librsvg2 libtiff libxml2 pango popt xorg-x11-libs zlib
atk-1.6.0-1
fontconfig-2.2.1-10
freetype-2.1.7-4
GConf2-2.6.0-7
gimp-2.0.4-0.fc2.1
gimp-data-extras-1.2.0-11
gimp-print-4.2.6-11
gimp-print-plugin-4.2.6-11
glib2-2.4.0-1
glibc-2.3.3-27
gtk2-2.4.7-2.5
gtkhtml2-2.6.0-1
libart_lgpl-2.3.16-2.1
libbonobo-2.6.2-1
libbonoboui-2.6.0-1
libcroco-0.4.0-4
libjpeg-6b-31.1
libpng-1.2.5-8
librsvg2-2.6.4-2
libtiff-3.5.7-16.1
libxml2-2.6.8-1
pango-1.4.0-2
popt-1.9.1-0.3
xorg-x11-libs-6.7.0-5
zlib-1.2.1.1-2.1
----------------------------------------

Hmmm, looks like we have the same gtk, so the problem must be
somewhere else.

[root@johngalt root]# rpm -V atk fontconfig freetype GConf2 gimp
prelink: /usr/bin/gimp-2.0: at least one of file's dependencies has
changed since prelinking
S.?.....    /usr/bin/gimp-2.0
prelink: /usr/lib/gimp/2.0/plug-ins/AlienMap: at least one of file's
dependencies has changed since prelinking
S.?.....    /usr/lib/gimp/2.0/plug-ins/AlienMap

[same message repeated at least 100 times for each gimp plug-in]

.M......  c /etc/ld.so.conf

------------------------
Hmmm, something really bad must have happened last night.  At this
point, I just re-run prelink, right?

Comment 8 Ken Barber 2004-09-18 19:31:27 EDT
Sorry about the false alarm...

I really, truly thought I had a smoking gun there, with a failure
right after updating a package, esp. since it was an update that
wouldn't even install for the first day or two (b0rken dependency or
something) after release...

But my problem ain't a bug.  I just removed & reinstalled Gimp with
YUM and everything works now.

Again, I'm sorry about the false alarm.  I'm impressed with how
quickly you repsonded, though, especially on a weekend.
Comment 9 Mark Richters 2004-09-19 06:31:54 EDT
Exactly the same here. I got the same messages from prelink, did a
reinstall and it works now. Thanks for the help and sorry for wasting
your time.
Comment 10 Nils Philippsen 2004-09-20 03:06:06 EDT
So maybe you two had a problem with prelink. I'll change the component
 so Jakub can take a look at it but since you both have working
systems now he might not have much material to debug ;-).
Comment 11 Jakub Jelinek 2004-09-24 03:07:12 EDT
prelink -V failures are expected immediately after you upgrade rpms
on a prelinked system and before prelink is rerun.
It shouldn't change anything on whether the binaries work or not.

If you think this is prelink's problem, I need the binaries and
all libraries they depend on in the state where they didn't work and
after reprelinking.
Comment 12 Alejandro Gonzalez Hernandez - Imoq 2004-10-01 11:18:54 EDT
I am sorry to add a "me too" without any helpful logfile, but I just
want to tell what happened me yesterday, which I think it's related to
this problem:

I was working with The Gimp (which I seldom do), had The Gimp and
gtk2+ updated to the latest releases from few days ago. I hadn't
updated x.org yet, so, the problem doesn't lie in the x.org update, I
think.

After a while of working, my X crashed and didn't come back. Reboot, X
didn't start and I found in my /var/log/messages many lines that said
something like:

kernel: unable to access beyond end of device

Or something like that, I didn't save such log, I am sorry. After
surfing for a little while I read about possible filesystem
corruption. Since I needed to continue working, I backed up /etc and
had to reinstall, formating /dev/hda3 (where / filesystem is) and
after the format and apply all the updates, everything seems to be
working all right now.

Oh, by the way, I tried to undo the prelink by running:

prelink -ua

but prelink did a Segmentation Fault and couldn't undo the prelink.

fsck didn't report any problem with the filesystem, neither with the
reinstall.
Comment 13 Nils Philippsen 2004-10-04 08:21:29 EDT
Alejandro, I seriously think that you have either a different or an
additional problem -- accesses beyond end of device are usually a sign
that file system meta data and partition tables (or logical volume
configuration) don't agree on how large a partition/logical volume is.
You probably have lost some data (probably not, then count yourself
lucky), you should backup you existing data and force a file system
check on your file systems.
Comment 14 Nils Philippsen 2004-10-04 08:25:23 EDT
As I can't reproduce the problem and don't have enough data to even
decide whether it's a gimp, gtk or other problem and because it seems
to be a transient that can be worked around easily (see comment #8),
I'll close this as WORKSFORME. There's a gimp-2.0.5-0.fc2.1 in
updates-testing, if you encounter the same problem there, please reopen.
Comment 15 Alejandro Gonzalez Hernandez - Imoq 2004-10-07 11:25:19 EDT
Nils:

As I commented above, I just reformatted the partition (didn't lose
any data, fortunatelly) and hadn't time to investigate what the issue
was. It is just it seemed very like the problem somebody described in
this bug (since I read in google that the corruption _could_ have been
due some prelink stuff).

Anyway, it is OK for me that this bug is closed, since I don't have
any way to reproduce it and I had to erease the log files.

Note You need to log in before you can comment on or make changes to this bug.