Bug 132931 - GUI login hangs
GUI login hangs
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: gnome-session (Show other bugs)
2
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Ray Strode [halfline]
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-09-19 19:25 EDT by Bill Shannon
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-10-26 03:34:44 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Bill Shannon 2004-09-19 19:25:30 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.3)
Gecko/20040913

Description of problem:
I upgraded from FC1 to FC2.  After upgrade, login to any regular
user account using the login GUI hangs.  Login as root succeeds.

I tried both my existing user account and a new user account I
created with no dot files.

After entering the username and password, it switch to the screen
that shows the icons across the bottom as pieces of the system are
initialized.  I get the metacity icon and then nothing.  Sometimes,
if I wait long enough or poke the system is just the right way, I
get some of the other icons, but I've never succeeded in getting all
of them and having the login finish.

In /var/log/messages I get:

Sep 16 21:48:13 dell bonobo-activation-server (shannon-1810): iid
OAFIID:BrokenNoType:20000808 has a NULL type
Sep 16 21:48:13 dell bonobo-activation-server (shannon-1810): invalid
character '#' in iid 'OAFIID:This#!!%$iid%^$%_|~!OAFIID_ContainsBadChars'
Sep 16 21:48:15 dell modprobe: FATAL: Error running install command
for sound_slot_0
Sep 16 21:48:15 dell modprobe: FATAL: Error running install command
for sound_slot_0
Sep 16 21:48:15 dell modprobe: FATAL: Error running install command
for sound_slot_1

I suspect the first two have something to do with the problem.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. login as non-root user
2.
3.
    

Actual Results:  login hangs

Expected Results:  login succeeds

Additional info:
Comment 1 Bill Shannon 2004-10-26 03:34:44 EDT
I figured out what the problem was.  All the home directories for
all the users were in /home/<user>, but because the automounter
wasn't working, and /home was being automounted, the login hung.

This should really be marked a duplicate of some automounter bug,
but I'm just going to close it as "not a bug" for now...

Note You need to log in before you can comment on or make changes to this bug.