Bug 132952 - unresolved symbols at quickcam.o
Summary: unresolved symbols at quickcam.o
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: kernel   
(Show other bugs)
Version: 3.0
Hardware: All Linux
medium
medium
Target Milestone: ---
Assignee: Arjan van de Ven
QA Contact: Brian Brock
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2004-09-20 11:15 UTC by Andy Shevchenko
Modified: 2007-11-30 22:07 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-09-20 13:26:20 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Andy Shevchenko 2004-09-20 11:15:32 UTC
Description of problem:

[root@localhost root]# depmod -a
depmod: *** Unresolved symbols in
/lib/modules/2.4.21-20.EL/kernel/drivers/usb/quickcam.o

[root@localhost root]# modinfo
/lib/modules/2.4.21-20.EL/kernel/drivers/usb/quickcam.o
filename:    /lib/modules/2.4.21-20.EL/kernel/drivers/usb/quickcam.o
description: "Logitech QuickCam USB driver"
author:      "See README"
license:     "GPL"
parm:        debug int, description "Sets the debug output (bitfield)"
parm:        keepsettings int, description "Keep picture settings
across one open to another (0-1)"
parm:        settle int, description "Let picture settle at device
open (0-1)"
parm:        subsample int, description "Sets subsampling (0-1)"
parm:        compress int, description "Enable compressed mode (0-1)"
parm:        frameskip int, description "How frequently capture frames
(0-10)"
parm:        quality int, description "Sets the picture quality (0-3)"
parm:        adaptive int, description "Automatic adaptive brightness
control (0-1)"
parm:        equalize int, description "Equalize image (0-1)"
parm:        retryerrors int, description "Retry if image capture
fails, otherwise return error code (0-1)"
parm:        compatible int, description "Enable workaround for bugs
in application programs (bitfield)"
parm:        video_nr int, description "Set videodevice number
(/dev/videoX)"

[root@localhost root]# insmod quickcam
Using /lib/modules/2.4.21-20.EL/kernel/drivers/usb/quickcam.o
/lib/modules/2.4.21-20.EL/kernel/drivers/usb/quickcam.o: unresolved
symbol video_register_device_Rc646ee0c
/lib/modules/2.4.21-20.EL/kernel/drivers/usb/quickcam.o: unresolved
symbol video_unregister_device_Rfb12c298
/lib/modules/2.4.21-20.EL/kernel/drivers/usb/quickcam.o: unresolved
symbol video_proc_entry_Rbb027214


Version-Release number of selected component (if applicable):
Kernel-2.4.21-20.EL from updates of RHEL 3AS.

Comment 1 Arjan van de Ven 2004-09-20 11:30:22 UTC
please only use modprobe not insmod; insmod doesn't resolve
dependencies...


Comment 2 Andy Shevchenko 2004-09-20 12:02:53 UTC
I have got the same result. Insmod in previous message is just shower,
not real usage.

[root@localhost root]# modprobe quickcam
/lib/modules/2.4.21-20.EL/kernel/drivers/usb/quickcam.o: unresolved
symbol video_register_device_Rc646ee0c
/lib/modules/2.4.21-20.EL/kernel/drivers/usb/quickcam.o: unresolved
symbol video_unregister_device_Rfb12c298
/lib/modules/2.4.21-20.EL/kernel/drivers/usb/quickcam.o: unresolved
symbol video_proc_entry_Rbb027214
/lib/modules/2.4.21-20.EL/kernel/drivers/usb/quickcam.o: insmod
/lib/modules/2.4.21-20.EL/kernel/drivers/usb/quickcam.ofailed
/lib/modules/2.4.21-20.EL/kernel/drivers/usb/quickcam.o: insmod
quickcam failed


Comment 3 Arjan van de Ven 2004-09-20 12:13:34 UTC
are you sure you got that quickcam.o from us ?? I don't see us
shipping it...


Comment 4 Andy Shevchenko 2004-09-20 13:26:20 UTC
Big, big sorry, I have confused due to start of my own built kernel.



Note You need to log in before you can comment on or make changes to this bug.