Bug 13296 - must use push for @INC to use the current directory
Summary: must use push for @INC to use the current directory
Status: CLOSED WORKSFORME
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: perl (Show other bugs)
(Show other bugs)
Version: 7.1
Hardware: i386 Linux
medium
medium
Target Milestone: ---
Assignee: Crutcher Dunnavant
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2000-06-30 20:55 UTC by Becky Miller
Modified: 2008-05-01 15:37 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-08-14 15:15:45 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Becky Miller 2000-06-30 20:55:26 UTC
We must include the line 
push(@INC, ".");
for perl script to find the require argument in the current directory.

Comment 1 Nalin Dahyabhai 2000-07-03 07:50:38 UTC
What do you get when you run "perl -V"?  I'm unable to reproduce this problem
with this test case:

foo1.pl:
	print("foo1\n");
foo2.pl:
	require "foo1.pl";

Running foo2 prints "foo1".

Comment 2 Cristian Gafton 2000-08-09 02:45:45 UTC
assigned to nalin

Comment 3 Nalin Dahyabhai 2000-08-20 05:22:48 UTC
Closing.


Note You need to log in before you can comment on or make changes to this bug.