Bug 132967 - use Name/GenericName properly, or not at all
use Name/GenericName properly, or not at all
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: gaim (Show other bugs)
2
All Linux
medium Severity medium
: ---
: ---
Assigned To: Daniel Reed
:
: 133090 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-09-20 10:57 EDT by Rex Dieter
Modified: 2007-11-30 17:10 EST (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-09-21 13:12:16 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
kde menu snapshot (24.99 KB, image/png)
2004-09-20 10:58 EDT, Rex Dieter
no flags Details

  None (edit)
Description Rex Dieter 2004-09-20 10:57:10 EDT
With a recent gaim update (currently gaim-0.82-0.FC2.src.rpm) a
.desktop file change was made (presumably because of bug #125847) to
set *both* 
Name=IM
and
GenericName=IM

IMO, this is wrong, and distorts/violates the spirit of the use of
GenericName.

For example, in KDE, the menu now looks kinda silly (see attachment).

Either use both Name/GenericName, and set them properly:
Name=gaim
GenericName=IM
or remove GenericName altogether, leaving just
Name=IM
Comment 1 Rex Dieter 2004-09-20 10:58:16 EDT
Created attachment 104017 [details]
kde menu snapshot
Comment 2 Daniel Reed 2004-09-20 12:36:39 EDT
In the snapshot, gaim is showing up as entry:
IM (IM)
amidst entries like:
IRC Client (IRC Client)
Kopete (Instant Messenger)
and un-qualified entries like:
Mozilla Mail

Is this a KDE problem? I'll let the interaction designers answer this.
Comment 3 Rex Dieter 2004-09-20 12:43:36 EDT
IRC Client (IRC Client) is the same problem as here, but for xchat.

un-qualified entries, like Mozilla, are those who do not have a
GenericName entry.  If you insist on labeling gaim as IM in the menu
(which I also don't agree with), then my point is that you shouldn't
use GenericName to duplicate this.

IMO, the Kopete example is one of proper GenericName usage.
Comment 4 Rex Dieter 2004-09-21 13:04:20 EDT
See also bug #133090 for similar issue with xchat
Comment 5 Daniel Reed 2004-09-21 13:08:22 EDT
*** Bug 133090 has been marked as a duplicate of this bug. ***
Comment 6 Daniel Reed 2004-09-21 13:12:16 EDT
gaim and xchat have both been changed to have no GenericName in
rawhide-20040921.

Note You need to log in before you can comment on or make changes to this bug.