Bug 132989 - cman_tool should exit non zero on all failures
cman_tool should exit non zero on all failures
Product: Red Hat Cluster Suite
Classification: Red Hat
Component: gfs (Show other bugs)
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Christine Caulfield
GFS Bugs
Depends On:
  Show dependency treegraph
Reported: 2004-09-20 14:18 EDT by Corey Marthaler
Modified: 2010-01-11 21:58 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2004-09-21 10:49:51 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Corey Marthaler 2004-09-20 14:18:46 EDT
Description of problem:
[root@morph-01 root]# cman_tool join
can't open cluster socket: Address family not supported by protocol
[root@morph-01 root]# echo $?

In this case it could even say something about needing to load the module.

How reproducible:
Comment 1 Christine Caulfield 2004-09-21 04:03:15 EDT
Hopefully expunged all error cases that don't return non-zero.

Please let me know if you find any more...I'm sure you will :)

Checking in join.c;
/cvs/cluster/cluster/cman/cman_tool/join.c,v  <--  join.c
new revision: 1.9; previous revision: 1.8
Comment 2 Corey Marthaler 2004-09-21 10:49:51 EDT
fix verified. 
Comment 3 Kiersten (Kerri) Anderson 2004-11-16 14:11:06 EST
Updating version to the right level in the defects.  Sorry for the storm.

Note You need to log in before you can comment on or make changes to this bug.