Bug 13299 - RFE: show 0x after io= when entering module parameters
Summary: RFE: show 0x after io= when entering module parameters
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: anaconda (Show other bugs)
(Show other bugs)
Version: 7.1
Hardware: i386 Linux
medium
medium
Target Milestone: ---
Assignee: Brock Organ
QA Contact:
URL:
Whiteboard:
Keywords: FutureFeature
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2000-06-30 21:25 UTC by Hans de Goede
Modified: 2008-05-01 15:37 UTC (History)
0 users

Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-12-08 19:52:43 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Hans de Goede 2000-06-30 21:25:58 UTC
Afaik old versiosn of redhat used to show "io=0x " instead of just "io= ",
since I concider myself sorta experienced and this just bit me (stupid) it
might be a good idea to add it for new users.

Comment 1 Matt Wilson 2000-07-13 16:13:12 UTC
Proposed patch is in review.

Comment 2 Matt Wilson 2000-07-13 16:44:42 UTC
will be in in next release.


Comment 3 Hans de Goede 2000-07-24 19:59:02 UTC
FYI: I don't see this (0x) in beta4 for the mcdx driver, this one has a
parameter list like:
mcdx=0x340,11

And there are more like this, so I don't think this can be fixed easily.


Comment 4 Matt Wilson 2000-07-24 21:07:17 UTC
This will only do io= for the next release.  Later, I will probably parse the
glob in module-info and take all the 0x prefixes from there, but it will be
deferred.


Comment 5 Michael Fulbright 2000-09-26 19:41:53 UTC
Matt please apply the patch and resolve this bug now that 7 has shipped.

Comment 6 Matt Wilson 2000-11-17 21:10:46 UTC
Verified that it shows up for ne module in current CVS.


Comment 7 Hans de Goede 2000-11-20 09:32:27 UTC
FYI, it already ws fixed for ne and the likes in 7.0. The problem is mscdx and
others which don't have an io=parameter but an other hex parameter.


Comment 8 Brock Organ 2000-12-08 20:55:53 UTC
verified that some devices (like ne2k) have proper 'io=0x' & 'irq=' lines, but
other devices don't ... this behavior is not consistent across modules ... a
better more consistent implementation may be implemented in a future release ...


Note You need to log in before you can comment on or make changes to this bug.