Bug 1330014 - eclipse-testng: FTBFS in rawhide due to testng no longer shipping "remote" classes
Summary: eclipse-testng: FTBFS in rawhide due to testng no longer shipping "remote" cl...
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: eclipse-testng
Version: rawhide
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Mat Booth
QA Contact: Fedora Extras Quality Assurance
URL: https://apps.fedoraproject.org/kosche...
Whiteboard:
Keywords:
Depends On: 1330027
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-04-25 09:51 UTC by Mat Booth
Modified: 2016-05-07 11:52 UTC (History)
2 users (show)

(edit)
Clone Of:
(edit)
Last Closed: 2016-05-07 11:52:57 UTC


Attachments (Terms of Use)

Description Mat Booth 2016-04-25 09:51:15 UTC
Description of problem:
Package eclipse-testng fails to build from source in rawhide.

This is because testng package no longer ships the "remote" classes used to transmit the test results from the testng runtime to the IDE.

Version-Release number of selected component (if applicable):
6.9.9-2.fc24

Steps to Reproduce:
koji build --scratch f25 eclipse-testng-6.9.9-2.fc24.src.rpm

Additional info:
This package is tracked by Koschei. See:
https://apps.fedoraproject.org/koschei/package/eclipse-testng

Comment 1 Fedora Update System 2016-04-25 17:37:33 UTC
testng-remote-1.0.0-0.2.gitfc5cfab.fc24 eclipse-testng-6.9.11.1-1.fc24 has been submitted as an update to Fedora 24. https://bodhi.fedoraproject.org/updates/FEDORA-2016-ff3c3212a4

Comment 2 Fedora Update System 2016-04-26 16:23:14 UTC
eclipse-testng-6.9.11.1-1.fc24, testng-remote-1.0.0-0.2.gitfc5cfab.fc24 has been pushed to the Fedora 24 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-ff3c3212a4

Comment 3 Fedora Update System 2016-05-07 11:52:53 UTC
eclipse-testng-6.9.11.1-1.fc24, testng-remote-1.0.0-0.2.gitfc5cfab.fc24 has been pushed to the Fedora 24 stable repository. If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.