Bug 133030 - samba connections start failing after between 15 and 20 minutes
samba connections start failing after between 15 and 20 minutes
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: samba (Show other bugs)
rawhide
i586 Linux
medium Severity medium
: ---
: ---
Assigned To: Jay Fenlason
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-09-20 18:58 EDT by Andy Grover
Modified: 2014-08-31 19:26 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-09-22 16:04:17 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Andy Grover 2004-09-20 18:58:06 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7)
Gecko/20040808 Firefox/0.9.3

Description of problem:
I have a bunch of FC2 and 1 rawhide box connecting to a WinXP share.
After 15-20 minutes, the rawhide box starts returning ls failures. The
only way to fix is to unmount and remount the share. The FC2 boxes
(samba-2.0.7-2.FC2) experience no such problem.

[root@grover2 ~]# umount desk
[root@grover2 ~]# mount desk
[root@grover2 ~]# cd desk/isos
[root@grover2 isos]# ls;sleep 900;ls;sleep 1200;ls
FC2-x86_64-disc1.iso  FC2-x86_64-disc2.iso  FC2-x86_64-disc3.iso 
FC2-x86_64-disc4.iso
FC2-x86_64-disc1.iso  FC2-x86_64-disc2.iso  FC2-x86_64-disc3.iso 
FC2-x86_64-disc4.iso
ls: .: Input/output error

dmesg shows the following:

smb_retry: signal failed [-3]
smb_add_request: request [03f21ee0, mid=19] timed out!


Version-Release number of selected component (if applicable):
samba-3.0.7-3

How reproducible:
Always

Steps to Reproduce:
1. Connect to samba share
2. cd to share
3. wait 20 minutes
4. ls
    

Actual Results:  an error

Expected Results:  the directory contents listed

Additional info:
Comment 1 Jay Fenlason 2004-09-21 10:48:22 EDT
I'll need the /etc/samba/smb.conf file from your client(s) and the 
command line you use to mount the share(s) to have any hope of 
reproducing this. 
 
If you're using smbfs, you probably need to change the component of 
this bug to "kernel", since Samba is not smbfs.  Also, if you're 
using smbfs, try switching to cifs, which is newer, more reliable, 
and is much better maintained. 
Comment 2 Andy Grover 2004-09-22 16:04:17 EDT
OK I'll use cifs, thanks.

Note You need to log in before you can comment on or make changes to this bug.