Bug 133042 - hal fails to create an entry in /etc/fstab for sr0 (firewire CDRW)
hal fails to create an entry in /etc/fstab for sr0 (firewire CDRW)
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: hal (Show other bugs)
3
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: David Zeuthen
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-09-20 23:35 EDT by raxet
Modified: 2013-03-05 22:41 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-09-22 03:06:46 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
kernel messages (31.94 KB, text/plain)
2004-09-20 23:37 EDT, raxet
no flags Details
lshal output (68.12 KB, text/plain)
2004-09-21 08:56 EDT, raxet
no flags Details
fstab (866 bytes, text/plain)
2004-09-21 08:58 EDT, raxet
no flags Details
output of hald --daemon=no --verbose=yes (51.94 KB, text/plain)
2004-09-21 23:39 EDT, raxet
no flags Details

  None (edit)
Description raxet 2004-09-20 23:35:10 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.2)
Gecko/20040809

Description of problem:
Boot, hal creates all needed entries except /dev/sr0

see attached kernel messages

Version-Release number of selected component (if applicable):
hal-0.2.97.cvs20040901-1

How reproducible:
Always

Steps to Reproduce:
1. updated to latest FC3t2
2. sr0 is missing in fstab
3.
    

Actual Results:  no entry for sr0

Expected Results:  entry for sr0

Additional info:
Comment 1 raxet 2004-09-20 23:37:40 EDT
Created attachment 104054 [details]
kernel messages
Comment 2 raxet 2004-09-20 23:38:29 EDT
Make note (from kernel messages) that firewire device is found:

Sep 20 20:23:52 raxet kernel: ieee1394: sbp2: Logged into SBP-2 device
Sep 20 20:23:52 raxet kernel:   Vendor: LITE-ON   Model: LTR-48125W  
     Rev: VS06
Sep 20 20:23:52 raxet kernel:   Type:   CD-ROM                       
     ANSI SCSI revision: 02
Sep 20 20:23:52 raxet kernel: sr0: scsi3-mmc drive: 12x/12x writer
cd/rw xa/form2 cdda tray
Comment 3 David Zeuthen 2004-09-21 03:27:44 EDT
Please submit a trace as detailed in 1. through 6. here

 http://freedesktop.org/Software/HalTraces

Thanks,
David
Comment 4 raxet 2004-09-21 08:54:45 EDT
06:56:50.974 [I] hald.c:317: hal 0.2.97.cvs20040901
06:56:50.975 [I] hald.c:321: Will not daemonize
Error binding to /var/run/hal/hotplug_socket: Address already in use

No output in kernel messages

See attached lshalraxet.txt for lshal output
Comment 5 raxet 2004-09-21 08:56:55 EDT
Created attachment 104061 [details]
lshal output
Comment 6 raxet 2004-09-21 08:58:57 EDT
Created attachment 104063 [details]
fstab
Comment 7 raxet 2004-09-21 09:00:33 EDT
06:56:50.974 [I] hald.c:317: hal 0.2.97.cvs20040901
06:56:50.975 [I] hald.c:321: Will not daemonize
Error binding to /var/run/hal/hotplug_socket: Address already in use

No output in kernel messages

See attached lshalraxet.txt and fstab.txt for lshal output, fstab
repectively

kernel 2.6.8-1.541 latest dev fc3t2
Comment 8 David Zeuthen 2004-09-21 09:12:21 EDT
You need to stop the existing hal daemon by either 'service haldaemon
stop' or 'pkill hald'. You can make sure that no hald is running if
'ps aux|grep hald' doesn't show anything. 

But looking at the lshal output from comment 5 and the fstab from
comment 6 it looks that everything works if /dev/cdrom1 is a symlink
to /dev/sr0. Is this the case?
Comment 9 raxet 2004-09-21 21:48:19 EDT
The problem is that /dev/cdrom1 is not a symlink to /dev/sr0 in fstab.
The entry in fstab is :
/dev/cdrom1 /mnt/cdrom1      udf,iso9660 noauto,owner,kudzu,ro 0 0

running hald --daemon=no --verbose=yes after pkill hald does allow me
to start K3b for example and burn an iso!

I will add the output for hald --daemon=no --verbose=yes
as an attachment. Mind you hald isn't stopped and the
Comment 10 raxet 2004-09-21 23:39:31 EDT
Created attachment 104104 [details]
output of hald --daemon=no --verbose=yes
Comment 11 David Zeuthen 2004-09-22 03:06:46 EDT
The debug output says

 10435: Found /dev/cdrom1 pointing to /dev/sr0 in/etc/fstab

This means that 'ls -l /dev/cdrom1' will give something like this

 lrwxrwxrwx  1 root root 3 Sep 22 02:04 /dev/cdrom1 -> sr0

Hence, accessing /dev/cdrom1 and /dev/sr0 from userspace is the very
same thing. Thus, you indeed have an entry in /etc/fstab for your
firewire CDRW. This is in fact an feature of hal/fstab-sync. Because
if we didn't check symlinks you would have *two* entries for drive,
nameonly one with /dev/sr0 and one with /dev/cdrom1.

So I'm closing this as NOTABUG.

Note You need to log in before you can comment on or make changes to this bug.