Bug 133055 - auto.master source change a serious regression
auto.master source change a serious regression
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: autofs (Show other bugs)
3
All Linux
medium Severity high
: ---
: ---
Assigned To: Jeffrey Moyer
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-09-21 05:03 EDT by Joe Orton
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version: 4.1.3-22
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-10-12 05:11:32 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Joe Orton 2004-09-21 05:03:55 EDT
Description of problem:
autofs-4.1.3-13 mentions this change:

- Only read one auto.master map (instead of concatenating all found
sources).

this is a serious regression since previous releases, where one could
rely upon using e.g. NIS for site-wide automounts e.g. /home, and then
define any local mounts e.g. /misc in /etc/auto.master.

Version-Release number of selected component (if applicable):
autofs-4.1.3-17

How reproducible:
always

Steps to Reproduce:
1. uncomment the /misc line in /etc/auto.master
2. service autofs reload
  
Actual results:
automounts defined from the NIS auto.master map disappear

Expected results:
automounts defined from the NIS auto.master map do not disappear and
are used in conjunction with those defined in /etc/auto.master.

Additional info:
Maybe if someone desires the new functionality then allow it to be
used with an /etc/sysconfig/autofs flag, but do not make it the
default behaviour.
Comment 1 Jeffrey Moyer 2004-09-22 18:48:08 EDT
Since I've taken over the package, the main pain points I've seen are
with using the Linux automounter in mixed environments.  Customers
expect it to operate in the same manner as the Sun automounter.  This
change was intended to bring the Linux automounter semantically closer
to the bahaviour of the Sun automounter.  Since you are having
problems with it, I will revert the change until such time as I
implement the +auto_master syntax in the master map.  Is this an
acceptable solution?  I'd prefer to not add another tunable to
/etc/sysconfig/autofs, but I will if I must.
Comment 2 Joe Orton 2004-09-23 08:04:45 EDT
My response as per fedora-devel:

I'm happy so long as the default behaviour doesn't change.  Having a
tunable to configure it to behave like Solaris seems reasonable to me,
FWIW.
Comment 3 Joe Orton 2004-10-08 12:16:27 EDT
Has this been fixed, Jeff?
Comment 4 Jeffrey Moyer 2004-10-11 08:31:30 EDT
Yes.  The current fc3 package version is 4.1.3-22, and defaults to the
old behaviour.
Comment 5 Joe Orton 2004-10-12 05:11:32 EDT
Thanks a lot, works for me now.

Note You need to log in before you can comment on or make changes to this bug.