Bug 133081 - Choosing sda over hda as primary boot
Choosing sda over hda as primary boot
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
3
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Jeremy Katz
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-09-21 11:48 EDT by Bjorn Ryborg
Modified: 2007-11-30 17:10 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-09-21 14:37:55 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Bjorn Ryborg 2004-09-21 11:49:00 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.2)
Gecko/20040809 Epiphany/1.3.8

Description of problem:
Anaconda now has the option of finding out what partition is the
primary boot option. 
I have a SATA (sda) and a IDE (hda) disk. SATA (sda) is the primarry
boot option in Anaconda and that is correct, but when rebooting, GRUB
looks for MBA at the IDE (hda) disk. Thats the wrong harddisk.

Anaconda did not write the correct detected disk as primary boot
device in GRUB.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Install hda and sda (SATA) disk in tower
2. Install Fedora core 3 Test 2
3. Folow the default install
4. Reboot
    

Actual Results:  The prompt shows "GRUB" and stops loading

Expected Results:  Loading Fedora

Additional info:
Comment 1 Jeremy Katz 2004-09-21 14:04:52 EDT
If you go to the advanced boot loader screen, you can swap the order
of drives.  Unfortunately, there's not a way on x86 hardware to
reliably detect this :(
Comment 2 Bjorn Ryborg 2004-09-21 14:28:14 EDT
Wrong, that was in Fedora Core 2. 

In Core 3 Test2 i have no option for disabling the hda. The only shown
option is the sda, but GRUB is gonna get installed on hda.

I had to disable my hda before i was able to install Fedora and get
GRUB to boot from sda.
Comment 3 Bjorn Ryborg 2004-09-21 14:31:10 EDT
By disabling hda i mean remove the IDE cable, so the only harddisk
connected was the SATA disk.
Comment 4 Jeremy Katz 2004-09-21 14:37:55 EDT
Trust me here... if you click the checkbox beside "Advanced Boot
Loader Options", you can sort the drives in a different order.  Look
and see, it's there :)
Comment 5 Bjorn Ryborg 2004-09-22 14:44:48 EDT
You were right, sorry ;-)
I have reinstalled 3 times, but could not reproduce the "bug". I dont
know what went wrong first time.

Note You need to log in before you can comment on or make changes to this bug.