Bug 133130 - arrays suscripts out of range + many undefined operations
Summary: arrays suscripts out of range + many undefined operations
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: tetex   
(Show other bugs)
Version: 3
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Jindrich Novy
QA Contact: David Lawrence
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2004-09-21 19:57 UTC by David Binderman
Modified: 2013-07-02 23:02 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-09-30 08:58:21 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description David Binderman 2004-09-21 19:57:18 UTC
Description of problem:

I just tried to compile package tcsh-6.13-3 from
Redhat Fedora Core 3 Test 2.

The compiler said

1.

writet1.c(1337): warning #175: subscript out of range

The source code is

                a1 = cc_get(-1);

I'm not sure what the fix is for this.

Further duplicates are

writet1.c(1351): warning #175: subscript out of range
writet1.c(1352): warning #175: subscript out of range
writet1.c(1353): warning #175: subscript out of range

The source code is

               if (cc_get(-1) == 3)
                    lastargOtherSubr3 = cc_get(-3);
                a1 = cc_get(-2) + 2;

I'm not sure what the fix is for this. Maybe cc_get() on a negative
number should be avoided.

2.

epdf.c:51: warning: operation on `new_charset' may be undefined
mapfile.c:255: warning: operation on `fm_tab' may be undefined
utils.c:56: warning: operation on `ff_buf_tab' may be undefined
utils.c:80: warning: operation on `fnstr_tab' may be undefined
utils.c:92: warning: operation on `fnstr_tab' may be undefined
config.c:88: warning: operation on `mapfiles' may be undefined
vfpacket.c:49: warning: operation on `vf_tab' may be undefined
vfpacket.c:71: warning: operation on `packet_tab' may be undefined
writeenc.c:93: warning: operation on `enc_tab' may be undefined
writeimg.c:45: warning: operation on `image_tab' may be undefined
type1.c:446: warning: operation on `tmpx' may be undefined
type1.c:525: warning: operation on `tmpx' may be undefined
type1.c:590: warning: operation on `tmpx' may be undefined
type1.c:845: warning: operation on `tmpx' may be undefined
type1.c:849: warning: operation on `tmpx' may be undefined
type1.c:853: warning: operation on `tmpx' may be undefined
type1.c:1544: warning: operation on `tmpx' may be undefined
type1.c:1582: warning: operation on `tmpx' may be undefined
type1.c:1590: warning: operation on `tmpx' may be undefined
type1.c:1590: warning: operation on `tmpi' may be undefined
type1.c:1632: warning: operation on `tmpx' may be undefined
type1.c:1640: warning: operation on `tmpx' may be undefined
type1.c:1640: warning: operation on `tmpi' may be undefined

This looks like a lot of undefined operations. Suggest re-work.


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:

Comment 1 Jindrich Novy 2004-09-22 07:53:13 UTC
Did you compiled tcsh or tetex? tcsh has no writet1.c ...


Note You need to log in before you can comment on or make changes to this bug.