Bug 133137 - Problems with non-latin letters in User Full Name
Summary: Problems with non-latin letters in User Full Name
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: system-config-users
Version: 3
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Nils Philippsen
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2004-09-21 20:23 UTC by Nikolay
Modified: 2007-11-30 22:10 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2004-09-24 20:29:57 UTC


Attachments (Terms of Use)

Description Nikolay 2004-09-21 20:23:07 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7)
Gecko/20040904 Firefox/0.9.3

Description of problem:
I tested in Fedora Core 3 (Bulgarian).
I put the user full name
<&#1053;&#1080;&#1082;&#1086;&#1083;&#1072;&#1081;
&#1057;&#1098;&#1088;&#1084;&#1072;&#1076;&#1078;&#1080;&#1077;&#1074;>
from (About My Self) menu, the name appear with junk charecters in
system-config-user main screen.
I am guessing the coding is a problem. 

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.Enter user full name in cyrrilic (non-latin)
2.Open system-config-user
3.See the name is with junk charecters
    

Actual Results:  the junk charecters in Full Name

Expected Results:  Full name in correct Bulgarian letters
<&#1053;&#1080;&#1082;&#1086;&#1083;&#1072;&#1081;
&#1057;&#1098;&#1088;&#1084;&#1072;&#1076;&#1078;&#1080;&#1077;&#1074;>

Additional info:

Comment 1 Nils Philippsen 2004-09-22 09:47:37 UTC
Which locale are you using?

Comment 2 Nikolay 2004-09-22 23:03:43 UTC
Bulgarian - here is my locale output
[nikolayds@localhost ~]$ locale
LANG=bg_BG.UTF-8
LC_CTYPE="bg_BG.UTF-8"
LC_NUMERIC="bg_BG.UTF-8"
LC_TIME="bg_BG.UTF-8"
LC_COLLATE="bg_BG.UTF-8"
LC_MONETARY="bg_BG.UTF-8"
LC_MESSAGES="bg_BG.UTF-8"
LC_PAPER="bg_BG.UTF-8"
LC_NAME="bg_BG.UTF-8"
LC_ADDRESS="bg_BG.UTF-8"
LC_TELEPHONE="bg_BG.UTF-8"
LC_MEASUREMENT="bg_BG.UTF-8"
LC_IDENTIFICATION="bg_BG.UTF-8"
LC_ALL=
[nikolayds@localhost ~]$

BTW the menu item <Users and Groups> is not translated

Comment 3 Nils Philippsen 2004-09-23 14:02:35 UTC
Could you please attach the user name you tried UTF-8 encoded as
text/plain to this bug? Above, I only see numeric HTML entities which
aren't that great to debug this particular problem ;-). Thanks.

Comment 4 Nikolay 2004-09-23 18:59:13 UTC
Ðиколай СÑÑмаджиев
that is put from windows machine. 


Comment 5 Nils Philippsen 2004-09-24 20:29:57 UTC
Should be fixed in 1.2.20-1.


Note You need to log in before you can comment on or make changes to this bug.