Bug 13317 - ppp.c does not compile against kernel-source-2.2.14-5.0
Summary: ppp.c does not compile against kernel-source-2.2.14-5.0
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: ppp   
(Show other bugs)
Version: 6.2
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Nalin Dahyabhai
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2000-07-01 21:56 UTC by David J. Mellor
Modified: 2008-05-01 15:37 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-12-15 00:08:37 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description David J. Mellor 2000-07-01 21:56:00 UTC
There is an error in the version of ppp.c supplied with
ppp-2.3.11-4.src.rpm. This error is only encountered if one attempts to
rebuild the ppp driver against the kernel sources in
kernel-source-2.2.14-5.0.src.rpm, by doing a 'make kernel' in the top-level
directory of the ppp tree. When one then builds the kernel modules in the
linux source tree via 'make modules', the build will fail with the
following error messages:

ppp.c:188: warning: static declaration for
`ppp_register_compressor_R9682e733' follows non-static
ppp.c:189: warning: static declaration for
`ppp_unregister_compressor_Ra1b928df' follows non-static
ppp.c: In function `rcv_proto_unknown':
ppp.c:2563: too few arguments to function `kill_fasync_Ra2013edf'
make[2]: *** [ppp.o] Error 1

The two warning messages seem to be due to the fact that the declarations
of ppp_register_compressor and ppp_unregister_compressor are not protected
by a #ifdef CONFIG_MODULES/#endif in the version of ppp.c supplied with
ppp-2.3.11-4.src.rpm. I don't know if this is serious or not, but the
problem with the invocation of kill_fasync is serious. In the kernel
sources, the definition of kill_fasync in linux/fs/fcntl.c is changed from:

void kill_fasync(struct fasync_struct *fa, int sig)

to:

void kill_fasync(struct fasync_struct *fa, int sig, int band)

This change was made by the patch file linux-2.2.14-sigio.patch in the
kernel-2.2.14-5.0.src.rpm package, and that patch modifies the version of
ppp.c supplied with the kernel to use the three argument version of
kill_fasync:

-       kill_fasync(ppp->tty->fasync, SIGIO);
+       kill_fasync(ppp->tty->fasunc, SIGIO, POLL_IN);

I believe that the same patch needs to be made to the version of ppp.c
supplied with the ppp-2.3.11-4.src.rpm package.


Note You need to log in before you can comment on or make changes to this bug.