Bug 133176 - APCI suspend (s3) doesn't work on Thinkpad T40
APCI suspend (s3) doesn't work on Thinkpad T40
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
3
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Dave Jones
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-09-22 00:04 EDT by Satish Balay
Modified: 2015-01-04 17:09 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-07-15 18:43:35 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
lspci output (1.51 KB, text/plain)
2004-09-22 00:06 EDT, Satish Balay
no flags Details
dmesg output (15.06 KB, text/plain)
2004-09-22 00:06 EDT, Satish Balay
no flags Details

  None (edit)
Description Satish Balay 2004-09-22 00:04:42 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.2)
Gecko/20040809

Description of problem:
Suspend with "echo 3 > /proc/acpi/sleep" does not work

Version-Release number of selected component (if applicable):
kernel-2.6.8-1.541

How reproducible:
Always

Steps to Reproduce:
1. install FC2T3 on a ThinkPad T40 (with selinux disabled)
2. boot
3. as root "echo 3 > /proc/acpi/sleep"
    

Actual Results:  Attempts to suspend - but comes back.


Expected Results:  suspend

Additional info:

The following gets logged into /var/log/messages on attempting to suspend:

Sep 21 23:05:55 localhost kernel: Stopping tasks:
==============================================================================================|
Sep 21 23:05:55 localhost kernel: Could not suspend device
0000:00:1d.7: error -5
Sep 21 23:05:55 localhost kernel: ACPI: PCI interrupt 0000:00:1f.1[A]
-> GSI 11 (level, low) -> IRQ 11
Sep 21 23:05:55 localhost kernel: ACPI: PCI interrupt 0000:00:1f.5[B]
-> GSI 11 (level, low) -> IRQ 11
Sep 21 23:05:55 localhost kernel: ACPI: PCI interrupt 0000:00:1f.6[B]
-> GSI 11 (level, low) -> IRQ 11
Sep 21 23:05:55 localhost kernel: PCI: Enabling device 0000:02:01.0
(0000 -> 0003)
Sep 21 23:05:55 localhost kernel: ACPI: PCI interrupt 0000:02:01.0[A]
-> GSI 11 (level, low) -> IRQ 11
Sep 21 23:05:55 localhost kernel: eth1: New link status: Connected (0001)
Sep 21 23:05:55 localhost kernel: hub 1-0:1.0: reactivate --> -22
Sep 21 23:05:55 localhost kernel: hub 1-0:1.0: reactivate --> -22
Sep 21 23:05:55 localhost kernel: hub 2-0:1.0: reactivate --> -22
Sep 21 23:05:55 localhost kernel: hub 3-0:1.0: reactivate --> -22
Sep 21 23:05:55 localhost gpm[2725]: *** info [mice.c(1766)]: 
Sep 21 23:05:55 localhost kernel: hub 4-0:1.0: reactivate --> -22
Sep 21 23:05:55 localhost kernel: Restarting tasks... done
Sep 21 23:05:55 localhost kernel: agpgart: Found an AGP 2.0 compliant
device at 0000:00:00.0.
Sep 21 23:05:55 localhost kernel: agpgart: Putting AGP V2 device at
0000:00:00.0 into 1x mode
Sep 21 23:05:55 localhost kernel: agpgart: Putting AGP V2 device at
0000:01:00.0 into 1x mode
Sep 21 23:05:55 localhost gpm[2725]: imps2: Auto-detected intellimouse
PS/2
Sep 21 23:05:55 localhost kernel: [drm] Loading R200 Microcode
Comment 1 Satish Balay 2004-09-22 00:06:06 EDT
Created attachment 104105 [details]
lspci output
Comment 2 Satish Balay 2004-09-22 00:06:54 EDT
Created attachment 104106 [details]
dmesg output
Comment 3 Satish Balay 2004-09-22 00:32:41 EDT
As in https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=124337
using 'modprobe -r ehch-hcd' send the laptop into suspend.

However on attempting to recover from suspend (by pressing the power
button) - it briefly recovers - and then immediately goes into
shutdown mode (stopping the services) - and then finally shutsdown.

I have APM issues as well with it - will add it to
https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=133105
Comment 4 Satish Balay 2004-10-12 19:11:41 EDT
I tried the 607 kernel today - with the same 'shutdown' behavior. 

However when I tried to use 'Fn' key to recover from suspend - it
worked! I guess somehow the key-binding for ACPI recover has changed
from the 'power switch' to the 'Fn' key - to be in sync with 'APM'.

Don't know if this is a BIOS change or some thing within linux-acpi...

I guess this issue can be considered resolved.

I still have the CDROM light lit when in 'S3' sleep - I guess I'll
have to wait for an upstream fix on this one.
Comment 5 Satish Balay 2004-10-13 12:38:31 EDT
Forgot to mention - I didn't have to 'modprobe -r ehci-hcd' before
using 'echo 3 > /proc/acpi/sleep' - so I gess that issue is also resolved
Comment 6 Dave Jones 2005-07-15 14:02:00 EDT
An update has been released for Fedora Core 3 (kernel-2.6.12-1.1372_FC3) which
may contain a fix for your problem.   Please update to this new kernel, and
report whether or not it fixes your problem.

If you have updated to Fedora Core 4 since this bug was opened, and the problem
still occurs with the latest updates for that release, please change the version
field of this bug to 'fc4'.

Thank you.
Comment 7 Satish Balay 2005-07-15 15:56:10 EDT
I think this issue [ability to ACPI suspend/resume] has been working for a while
[works with 2.6.12-1.1372_FC3 as well]

However on suspend the cd light still blinks. So I'll continue to use APM. 

There is also a stack trace in /var/log/messages - but thats another bugzilla
entry https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=134905

This one can be closed.

thanks,

Note You need to log in before you can comment on or make changes to this bug.