Bug 133187 - Unable to start hal-device-manager
Unable to start hal-device-manager
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: hal (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: David Zeuthen
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-09-22 06:57 EDT by Daniel Malmgren
Modified: 2013-03-05 22:41 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-09-22 07:07:06 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Daniel Malmgren 2004-09-22 06:57:30 EDT
Description of problem:
Since last rawhide update hal-device-manager refuses to start.

Version-Release number of selected component (if applicable):
hal-gnome-0.2.98-4

How reproducible:
100%

Steps to Reproduce:
1. Try to start it
  
Actual results:
[~#] hal-device-manager
Traceback (most recent call last):
  File "/usr/bin/hal-device-manager", line 15, in ?
    DeviceManager()
  File "/usr/share/hal/device-manager/DeviceManager.py", line 81, in
__init__
    self.update_device_list()
  File "/usr/share/hal/device-manager/DeviceManager.py", line 195, in
update_device_list
    self.virtual_root = self.build_device_tree()
  File "/usr/share/hal/device-manager/DeviceManager.py", line 269, in
build_device_tree
    parent_name = properties["info.parent"]
TypeError: unsubscriptable object
Comment 1 David Zeuthen 2004-09-22 07:07:06 EDT
You need the latest dbus packages - version 0.22-7 should work. Feel
free to reopen this bug report if this doesn't help.
Comment 2 Juraj Wagner 2005-01-24 03:30:43 EST
The same problem with:
 dbus 0.22-10
 hal-0.4.6-1.FC3
 hal-gnome-0.4.6-1.FC3.

Note You need to log in before you can comment on or make changes to this bug.