Bug 1331957 - Segmentation fault when running liveusb-creator.
Summary: Segmentation fault when running liveusb-creator.
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: liveusb-creator
Version: 23
Hardware: x86_64
OS: Linux
unspecified
unspecified
Target Milestone: ---
Assignee: Luke Macken
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-04-30 15:03 UTC by Doug Herr
Modified: 2017-01-16 16:01 UTC (History)
8 users (show)

(edit)
Clone Of:
(edit)
Last Closed: 2016-05-02 16:29:28 UTC


Attachments (Terms of Use)
Cut and paste of console output. (16.57 KB, text/plain)
2016-04-30 15:03 UTC, Doug Herr
no flags Details
dmesg output (112.50 KB, text/plain)
2016-04-30 15:10 UTC, Doug Herr
no flags Details

Description Doug Herr 2016-04-30 15:03:34 UTC
Created attachment 1152589 [details]
Cut and paste of console output.

Description of problem: 
liveusb-creator gives a Segmentation fault


Version-Release number of selected component (if applicable):
liveusb-creator-3.93.3-1.fc23.noarch
qt5-qtquickcontrols-5.6.0-3.fc23.x86_64


How reproducible:
Run liveusb-creator_polkit as user or run liveusb-creator via sudo.

Steps to Reproduce:
1. Run liveusb-creator


Actual results:
Segmentation fault

Expected results:
Application opens and runs.

Additional info:
The window does appear for about a second and then disappears.

Comment 1 Doug Herr 2016-04-30 15:10 UTC
Created attachment 1152590 [details]
dmesg output

Comment 2 Martin Bříza 2016-05-02 09:21:34 UTC
Hello Doug,
it seems you're using the nvidia driver, is that correct? In that case I can't really provide assistance.

Comment 3 Doug Herr 2016-05-02 16:28:57 UTC
Yes, that is correct.  I had checked that the issue also showed up using a virtualbox install but that was either a different issue or it was also hitting an issue with the nvidia driver of the host. I just made sure that the issue is caused by nvidia by booting up an install that I have on an old hard drive.  I fully updated that install and was able to open liveusb-creator without error using install which uses nouveau.

I will see if I can close this bug.

Comment 4 Matt Hirsch 2016-09-24 23:28:22 UTC
This definitely does seem like a bug...

It is a bug in qt5, which seems to be related to loading the wrong OpenGL library.

You can read more about it here:
https://bugs.launchpad.net/ubuntu/+source/python-qt4/+bug/941826
https://github.com/Ultimaker/Cura/issues/385

It sounds like other applications have decided to fix it. You can, I hope, appreciate the unpleasant confusion that surrounds the experience of finding out that a basic disk manipulation tool I've been using for years suddenly cares what brand of GPU I'm using.

Comment 5 Matthias 2016-09-29 22:26:02 UTC
I agree with comment no. 4! If a program doesn't work with a certain driver but a whole systems runs fine with the same driver something is wrong with the program.

Comment 6 Martin Bříza 2016-09-30 10:24:16 UTC
liveusb-creator will be deprecated in favor of the mediawriter package. Please try installing that, as far as I know from the reports, it does not exhibit this behavior.

Comment 8 Paul W. Frields 2016-10-03 18:52:12 UTC
The website will change with the release of Fedora 25, as we are testing the mediawriter with the current pre-releases.

Comment 9 Richard Shaw 2017-01-15 16:59:57 UTC
FYI, Just downloaded F25 and LiveUSB Creator is still being referenced....

Comment 10 Paul W. Frields 2017-01-16 16:01:42 UTC
Fixed on master of website, should be live soon.


Note You need to log in before you can comment on or make changes to this bug.