Bug 133242 - up2date-lite doesn't build properly on solaris (Makefile, buildpackage.sh issues)
Summary: up2date-lite doesn't build properly on solaris (Makefile, buildpackage.sh iss...
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: up2date   
(Show other bugs)
Version: 4.0
Hardware: sparc Linux
medium
medium
Target Milestone: ---
: ---
Assignee: Jason Connor
QA Contact: Max Spevack
URL:
Whiteboard:
Keywords:
Depends On:
Blocks: 114967
TreeView+ depends on / blocked
 
Reported: 2004-09-22 18:35 UTC by Scott Seago
Modified: 2014-03-31 01:37 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-05-10 18:06:16 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
buildpackage.sh/Makefile/rhnsd.init patch (6.98 KB, patch)
2004-09-22 18:39 UTC, Scott Seago
no flags Details | Diff

Description Scott Seago 2004-09-22 18:35:34 UTC
Description of problem:
up2date-lite doesn't build properly on solaris (Makefile,
buildpackage.sh issues).

In buildpackage.sh:
1) some additional parameteters need to be passed to make
2) /etc/init.d/rhnsd needs to be moved out of /opt/redhat
3) needs misc. additional changes to get solaris package to build
properly.

In Makefile:
1) needs misc. path changes to reflect solaris build environment
2) installation of rhnsd.sysconfig and rhnsd.init missing
3) parameters used for compilation of rhnsd.c resulted in paths are
being set to the temporary build/install location rather than the
destination install location
4) Certain directories/files missing in the resulting solaris package
(/var/run, /etc/init.d)
5) need to export SUBPATH so that actions/Makefile installs properly

rhnsd.init:
need to use $PREFIX/var/run/rhnsd.pid instead of /var/run/rhnsd.pid

patch will be attached.

Comment 1 Scott Seago 2004-09-22 18:39:16 UTC
Created attachment 104139 [details]
buildpackage.sh/Makefile/rhnsd.init patch

This includes all changes I made in order to build a working RHATu2d solaris
package on rhnsun3.

One of my changes seems to be a reversion of a prior change to buildpackage.sh
(using gnupro install rather than /usr/ucb/install) as /usr/ucb/install is not
currently installed on rhnsun3. If the latter is preferable in all cases, we
should remove that section of the patch.

Comment 2 Adrian Likins 2004-10-07 16:28:03 UTC
I'll take a look at the patch

Comment 3 Adrian Likins 2004-10-11 20:04:56 UTC
applied to cvs

Comment 4 Adrian Likins 2005-05-10 18:06:16 UTC
using a  different codebase now, so setting to notabug


Note You need to log in before you can comment on or make changes to this bug.