Bug 1332434 - please, update assimp
Summary: please, update assimp
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: assimp
Version: 23
Hardware: x86_64
OS: Linux
unspecified
high
Target Milestone: ---
Assignee: Rich Mattes
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks: 1339158
TreeView+ depends on / blocked
 
Reported: 2016-05-03 08:00 UTC by jan p. springer
Modified: 2016-05-29 17:49 UTC (History)
4 users (show)

Fixed In Version: assimp-3.2.0-1.fc24
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-05-29 17:49:45 UTC
Type: Bug


Attachments (Terms of Use)

Description jan p. springer 2016-05-03 08:00:25 UTC
Description of problem:

assimp in f23 is at 3.1.1. please, update to 3.2 or newer.

Version-Release number of selected component (if applicable):

3.1.1

Comment 1 Ben Rosser 2016-05-09 17:15:30 UTC
Among other things, the game Pioneer [1] depends on assimp >= 3.2. It'd be awesome if you could upgrade the package in at least Rawhide and F24.

[1] http://pioneerspacesim.net/

Comment 2 Rich Mattes 2016-05-10 00:53:18 UTC
I will try to update assimp to 3.2 in rawhide and f24 in the coming days.  I will look at updating f23 as well, but it may run afoul of the stable updates policy: https://fedoraproject.org/wiki/Updates_Policy#Stable_Releases

Comment 3 Antonio T. (sagitter) 2016-05-20 15:15:11 UTC
(In reply to Ben Rosser from comment #1)
> Among other things, the game Pioneer [1] depends on assimp >= 3.2. It'd be
> awesome if you could upgrade the package in at least Rawhide and F24.
> 
> [1] http://pioneerspacesim.net/

I'm going to package Pioneer. You too?

Comment 4 Ben Rosser 2016-05-20 17:04:48 UTC
(In reply to Antonio Trande from comment #3)
> (In reply to Ben Rosser from comment #1)
> > Among other things, the game Pioneer [1] depends on assimp >= 3.2. It'd be
> > awesome if you could upgrade the package in at least Rawhide and F24.
> > 
> > [1] http://pioneerspacesim.net/
> 
> I'm going to package Pioneer. You too?

I was thinking about it, but I was going to actually try playing the game first (which I then couldn't do because of the assimp dependency :( ).

I'd be happy to review if you did package it (and maybe comaintain too?).

Comment 5 Antonio T. (sagitter) 2016-05-21 17:47:58 UTC
(In reply to Ben Rosser from comment #4)
> (In reply to Antonio Trande from comment #3)
> > (In reply to Ben Rosser from comment #1)
> > > Among other things, the game Pioneer [1] depends on assimp >= 3.2. It'd be
> > > awesome if you could upgrade the package in at least Rawhide and F24.
> > > 
> > > [1] http://pioneerspacesim.net/
> > 
> > I'm going to package Pioneer. You too?
> 
> I was thinking about it, but I was going to actually try playing the game
> first (which I then couldn't do because of the assimp dependency :( ).
> 
> I'd be happy to review if you did package it (and maybe comaintain too?).

I have update assimp (hope my patches are correct): http://copr-fe.cloud.fedoraproject.org/coprs/sagitter/Ipopt-EPEL/build/292270/

I'm testing Pioneer, but I see that assimp-3.2 is not recognized correctly.

Comment 6 Simon Chopin 2016-05-21 21:40:55 UTC
For the record, in the matter of Pioneer we provide a repo with most of the third-party dependencies at http://github.com/pioneerspacesim/pioner-thirdparty

(sorry for the shameless plug, but since we have apparently two would-be players ending up here, I thought it useful)

Comment 7 Fedora Update System 2016-05-25 12:37:09 UTC
assimp-3.2.0-1.fc24 cppcheck-1.73-2.fc24 dvblinkremote-0.2.0-0.8.beta.fc24 libmediainfo-0.7.85-2.fc24 mrpt-1.3.2-7.fc24 qt5-qt3d-5.6.0-3.fc24 spring-100.0-6.fc24 tinyxml2-3.0.0-1.fc24 has been submitted as an update to Fedora 24. https://bodhi.fedoraproject.org/updates/FEDORA-2016-da1be793dc

Comment 8 Fedora Update System 2016-05-25 12:37:18 UTC
assimp-3.2.0-1.fc24 cppcheck-1.73-2.fc24 dvblinkremote-0.2.0-0.8.beta.fc24 libmediainfo-0.7.85-2.fc24 mrpt-1.3.2-7.fc24 qt5-qt3d-5.6.0-3.fc24 spring-100.0-6.fc24 tinyxml2-3.0.0-1.fc24 has been submitted as an update to Fedora 24. https://bodhi.fedoraproject.org/updates/FEDORA-2016-da1be793dc

Comment 9 Antonio T. (sagitter) 2016-05-25 18:09:13 UTC
(In reply to Fedora Update System from comment #8)
> assimp-3.2.0-1.fc24 cppcheck-1.73-2.fc24 dvblinkremote-0.2.0-0.8.beta.fc24
> libmediainfo-0.7.85-2.fc24 mrpt-1.3.2-7.fc24 qt5-qt3d-5.6.0-3.fc24
> spring-100.0-6.fc24 tinyxml2-3.0.0-1.fc24 has been submitted as an update to
> Fedora 24. https://bodhi.fedoraproject.org/updates/FEDORA-2016-da1be793dc

Why not on f23 ?

Comment 10 Rich Mattes 2016-05-26 01:03:33 UTC
Because doing so would be against the stable update guidelines:

https://fedoraproject.org/wiki/Updates_Policy#Stable_Releases

> Package maintainers MUST: 
> - Avoid Major version updates, ABI breakage or API changes if at all possible. 

In this case, assimp 3.2 introduces a new SOVERSION, which is a clear ABI breakage.  If someone has local software installed that's compiled against assimp (e.g. someone has downloaded ROS and built rviz from source), then updating the system would break their software until they rebuild their local software.

If it's really important to get it upgraded in f23, we can request an exception from FESCo, provide justification, and see what they say:
https://fedoraproject.org/wiki/Updates_Policy#Exceptions

Comment 11 Rich Mattes 2016-05-26 01:40:41 UTC
I take that back - I don't know why I got it in my head that assimp's soname changed between 3.1.1 and 3.2.0.  It looks like both provide libassimp.so.3.

It looks like 3.1.1 and 3.2.0 are abi compatible based on abi-compliance-checker.  I'll double-check everything, and if it looks good I'll update f23.

Comment 12 Fedora Update System 2016-05-26 05:04:00 UTC
assimp-3.2.0-1.fc24, cppcheck-1.73-2.fc24, dvblinkremote-0.2.0-0.8.beta.fc24, libmediainfo-0.7.85-2.fc24, mrpt-1.3.2-7.fc24, qt5-qt3d-5.6.0-3.fc24, spring-100.0-6.fc24, tinyxml2-3.0.0-1.fc24 has been pushed to the Fedora 24 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-da1be793dc

Comment 13 jan p. springer 2016-05-26 11:31:18 UTC
(In reply to Rich Mattes from comment #11)
> I take that back - I don't know why I got it in my head that assimp's soname
> changed between 3.1.1 and 3.2.0.  It looks like both provide libassimp.so.3.
> 
> It looks like 3.1.1 and 3.2.0 are abi compatible based on
> abi-compliance-checker.  I'll double-check everything, and if it looks good
> I'll update f23.

that would be great, thanks.

Comment 14 Fedora Update System 2016-05-29 17:49:39 UTC
assimp-3.2.0-1.fc24, cppcheck-1.73-2.fc24, dvblinkremote-0.2.0-0.8.beta.fc24, libmediainfo-0.7.85-2.fc24, mrpt-1.3.2-7.fc24, qt5-qt3d-5.6.0-3.fc24, spring-100.0-6.fc24, tinyxml2-3.0.0-1.fc24 has been pushed to the Fedora 24 stable repository. If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.