Bug 133264 - Kernel Panic in VMWare 4.5.2
Summary: Kernel Panic in VMWare 4.5.2
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: kernel
Version: 3
Hardware: i686
OS: Linux
medium
high
Target Milestone: ---
Assignee: Dave Jones
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2004-09-22 20:04 UTC by Mark Haney
Modified: 2015-01-04 22:09 UTC (History)
4 users (show)

(edit)
Clone Of:
(edit)
Last Closed: 2004-11-21 03:09:24 UTC


Attachments (Terms of Use)

Description Mark Haney 2004-09-22 20:04:57 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.2)
Gecko/20040803

Description of problem:
No Volume Groups Found
No Volume Groups Found
No Volume Groups Found
mount: error 2 mounting ext3
mount: error 2 mounting none
switchroot: mount failed:22
umount /initrd/dev failed: 2
Kernel panic - not syncing: Attempted to kill init!


This is the error I get when trying to load FC3t2 for the first time
after an install in VMWare4.5.2.



Version-Release number of selected component (if applicable):
kernel-2.6.8-1.541

How reproducible:
Always

Steps to Reproduce:
1.Boot virtual machine
2.
3.
    

Actual Results:  Get the kernel panic.

Expected Results:  Expected to see a booted kernel.

Additional info:

Comment 1 Eric Beyer 2004-09-23 15:18:18 UTC
I have also experienced the same issue when installing Fedora Core 3
Test 2 in VMWare (4.5.2 build 8848). This issue only seems to exist if
you accept the default partitioning (LVM). I did a subsequent install
using XFS (linux xfs at the boot prompt) and it appears to boot fine. 

The kernel used in my case is the 2.6.8-1.541smp. I have a screen shot
which I have not attached as it says exactly what Mark listed in the
original bug report. I will see if I can find a way to debug this when
time permits. - Thanks!

Comment 2 Mark Haney 2004-09-24 12:08:54 UTC
I cannot confirm that using 'linux xfs' at the boot prompt fixes the
problem.  I tried this yesterday and got the error after reboot.  

Comment 3 Eric Beyer 2004-09-24 13:56:54 UTC
I should have clarified what I meant better, using linux xfs at the
installer boot prompt, changing the default partitioning from LVM to
XFS (other filesystems such as ext2fs or ext3fs probably work too) and
then installing works. I will review my steps to make sure that is the
steps I took.

Comment 4 Mark Haney 2004-09-24 18:56:42 UTC
Yes you are correct.  I realized that is what I missed after posting
my other comment.  It seems the problem is solely related to LVM,
because I installed T2 just fine using ext3 after removing the
VolGroup partition/volume in Disk Druid.  

Comment 5 Ralph Angenendt 2004-09-25 20:56:28 UTC
I can confirm that: The problem only arises with LVM - I did two
installs today with the manual "disk druid" partitioning and tried it
with xfs and ext3. Both installs did not give me a kernel panic as the
install with LVM did.

Comment 6 Dave Jones 2004-11-20 20:27:24 UTC
still a problem with latest kernels ?

Comment 7 Warren Togami 2004-11-21 03:09:24 UTC
FC3 final works fine for me.

Comment 8 Eric Beyer 2004-11-21 03:19:27 UTC
FC3 final works fine here as well, thanks!


Note You need to log in before you can comment on or make changes to this bug.