Bug 133264 - Kernel Panic in VMWare 4.5.2
Kernel Panic in VMWare 4.5.2
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
3
i686 Linux
medium Severity high
: ---
: ---
Assigned To: Dave Jones
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-09-22 16:04 EDT by Mark Haney
Modified: 2015-01-04 17:09 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-11-20 22:09:24 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Mark Haney 2004-09-22 16:04:57 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.2)
Gecko/20040803

Description of problem:
No Volume Groups Found
No Volume Groups Found
No Volume Groups Found
mount: error 2 mounting ext3
mount: error 2 mounting none
switchroot: mount failed:22
umount /initrd/dev failed: 2
Kernel panic - not syncing: Attempted to kill init!


This is the error I get when trying to load FC3t2 for the first time
after an install in VMWare4.5.2.



Version-Release number of selected component (if applicable):
kernel-2.6.8-1.541

How reproducible:
Always

Steps to Reproduce:
1.Boot virtual machine
2.
3.
    

Actual Results:  Get the kernel panic.

Expected Results:  Expected to see a booted kernel.

Additional info:
Comment 1 Eric Beyer 2004-09-23 11:18:18 EDT
I have also experienced the same issue when installing Fedora Core 3
Test 2 in VMWare (4.5.2 build 8848). This issue only seems to exist if
you accept the default partitioning (LVM). I did a subsequent install
using XFS (linux xfs at the boot prompt) and it appears to boot fine. 

The kernel used in my case is the 2.6.8-1.541smp. I have a screen shot
which I have not attached as it says exactly what Mark listed in the
original bug report. I will see if I can find a way to debug this when
time permits. - Thanks!
Comment 2 Mark Haney 2004-09-24 08:08:54 EDT
I cannot confirm that using 'linux xfs' at the boot prompt fixes the
problem.  I tried this yesterday and got the error after reboot.  
Comment 3 Eric Beyer 2004-09-24 09:56:54 EDT
I should have clarified what I meant better, using linux xfs at the
installer boot prompt, changing the default partitioning from LVM to
XFS (other filesystems such as ext2fs or ext3fs probably work too) and
then installing works. I will review my steps to make sure that is the
steps I took.
Comment 4 Mark Haney 2004-09-24 14:56:42 EDT
Yes you are correct.  I realized that is what I missed after posting
my other comment.  It seems the problem is solely related to LVM,
because I installed T2 just fine using ext3 after removing the
VolGroup partition/volume in Disk Druid.  
Comment 5 Ralph Angenendt 2004-09-25 16:56:28 EDT
I can confirm that: The problem only arises with LVM - I did two
installs today with the manual "disk druid" partitioning and tried it
with xfs and ext3. Both installs did not give me a kernel panic as the
install with LVM did.
Comment 6 Dave Jones 2004-11-20 15:27:24 EST
still a problem with latest kernels ?
Comment 7 Warren Togami 2004-11-20 22:09:24 EST
FC3 final works fine for me.
Comment 8 Eric Beyer 2004-11-20 22:19:27 EST
FC3 final works fine here as well, thanks!

Note You need to log in before you can comment on or make changes to this bug.