Bug 133302 - I cannot choose options in a combo box of a HTML code.
I cannot choose options in a combo box of a HTML code.
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: firefox (Show other bugs)
3
i386 Linux
medium Severity low
: ---
: ---
Assigned To: Christopher Aillon
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-09-22 20:24 EDT by Takayuki Ogawa
Modified: 2007-11-30 17:10 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-10-10 02:28:15 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Takayuki Ogawa 2004-09-22 20:24:19 EDT
Description of problem:
I cannot choose the option "b" described in the following HTML code.
<html>
<body>
      <input id="knob-resolve" type="radio" name="knob" value="resolve">
      <label for="knob-resolve">
        text
        <select name="resolution">
          <option value="a">a</option>
          <option value="b">b</option>
        </select>
        </label>
</body>
</html>
But I can choose it when we open the file by Internet Explorer 6.0.
Is the HTML code wrong?

Version-Release number of selected component (if applicable):
firefox-0.10.0-1.0PR1.0

How reproducible:
Always

Steps to Reproduce:
1. Start Firefox.
2. Open the file.
3. Try to choose the option.
  
Actual results: We cannot choose the option.


Expected results: We can choose the option correctly.


Additional info:
Comment 1 Christopher Aillon 2004-10-08 08:21:56 EDT
Should be fixed in rawhide.  Please try updating.
Comment 2 Takayuki Ogawa 2004-10-10 01:35:44 EDT
I tried after updating. But this bug does not seem to be fixed.
The version of firefox is 0.10.1-1.0PR1.9.
Comment 3 Christopher Aillon 2004-10-10 02:28:15 EDT
It does work for me.  You have to hold it down in order to get the
list to stay up long enough to select it.  The reason for this is
because you have the <select> inside of the <label>.  That means that
anything in the select will click on the radio button to select it and
give it focus.  You probably want to do:

<html>
<body>
      <input id="knob-resolve" type="radio" name="knob" value="resolve">
      <label for="knob-resolve">
        text
      </label>
      <select name="resolution">
        <option value="a">a</option>
        <option value="b">b</option>
      </select>
</body>
</html>



Resolving NOTABUG because it works the way its supposed to.

Note You need to log in before you can comment on or make changes to this bug.