Bug 133332 - ICE i386/x86_64 -O2 or -Os
ICE i386/x86_64 -O2 or -Os
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: gcc34 (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Jakub Jelinek
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-09-23 04:44 EDT by Warren Togami
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-09-26 16:12:35 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
ICE.txt.gz (8.96 KB, application/octet-stream)
2004-09-23 04:47 EDT, Warren Togami
no flags Details

  None (edit)
Description Warren Togami 2004-09-23 04:44:56 EDT
Description of problem:
My broken & incomplete implementation of AES causes gcc-3.4.2-2 to ICE
on both i386 and x86_64 with -O2 or -Os.  -O1 does not ICE.

[warren@fedora64 aes-crash-gcc]$ make
gcc -Wall -O2 -c -g aes.c -o aes.o
aes.c: In function `SubBytes':
aes.c:267: internal compiler error: in find_function_data, at
function.c:315

Version-Release number of selected component (if applicable):
gcc-3.4.2-2
Comment 1 Warren Togami 2004-09-23 04:47:13 EDT
Created attachment 104169 [details]
ICE.txt.gz

Compressed text containing ICE dump.
Comment 2 Warren Togami 2004-09-23 16:26:22 EDT
Note that gcc4 survives.
Comment 3 Jakub Jelinek 2004-09-26 16:12:35 EDT
Submitted upstream.
Warren, please reconsider use of VLAs everywhere, it is IMHO not
a good idea.  Furthermore, please look at SubBytes routine, to me
it looks like a nop.
Comment 4 Jakub Jelinek 2004-09-26 16:13:54 EDT
http://gcc.gnu.org/PR17682 FYI.

Note You need to log in before you can comment on or make changes to this bug.