Bug 133336 - Yum downloads lots of rpm files 2 times
Yum downloads lots of rpm files 2 times
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: yum (Show other bugs)
rawhide
All Linux
medium Severity high
: ---
: ---
Assigned To: Jeremy Katz
:
Depends On: 131095
Blocks:
  Show dependency treegraph
 
Reported: 2004-09-23 05:21 EDT by Robert Scheck
Modified: 2014-01-21 17:49 EST (History)
1 user (show)

See Also:
Fixed In Version: 2.4.0-2
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-09-10 07:48:59 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Robert Scheck 2004-09-23 05:21:31 EDT
Description of problem:
--- snipp ---
# grep httpd-suexec-2.0.51-6 access_log 
fedora.testnet - - [23/Sep/2004:10:57:11 +0200] "GET /files/RPMS/httpd-suexec-2.0.51-6.i386.rpm HTTP/1.1" 401 498 "-" "urlgrabber/2.9.0"
fedora.testnet - user [23/Sep/2004:10:57:14 +0200] "GET /files/RPMS/httpd-suexec-2.0.51-6.i386.rpm HTTP/1.1" 206 17872 "-" "urlgrabber/2.9.0"
fedora.testnet - - [23/Sep/2004:11:07:54 +0200] "GET /files/RPMS/httpd-suexec-2.0.51-6.i386.rpm HTTP/1.1" 401 498 "-" "urlgrabber/2.9.0"
fedora.testnet - user [23/Sep/2004:11:07:57 +0200] "GET /files/RPMS/httpd-suexec-2.0.51-6.i386.rpm HTTP/1.1" 200 28595 "-" "urlgrabber/2.9.0"
# grep php-mysql-4.3.8-11 access_log 
fedora.testnet - - [23/Sep/2004:10:56:57 +0200] "GET /files/RPMS/php-mysql-4.3.8-11.i386.rpm HTTP/1.1" 401 498 "-" "urlgrabber/2.9.0"
fedora.testnet - user [23/Sep/2004:10:57:00 +0200] "GET /files/RPMS/php-mysql-4.3.8-11.i386.rpm HTTP/1.1" 206 15332 "-" "urlgrabber/2.9.0"
fedora.testnet - - [23/Sep/2004:11:07:39 +0200] "GET /files/RPMS/php-mysql-4.3.8-11.i386.rpm HTTP/1.1" 401 498 "-" "urlgrabber/2.9.0"
fedora.testnet - user [23/Sep/2004:11:07:42 +0200] "GET /files/RPMS/php-mysql-4.3.8-11.i386.rpm HTTP/1.1" 200 51183 "-" "urlgrabber/2.9.0"
# grep rpm-libs-4.2.3-10 access_log
fedora.testnet - - [23/Sep/2004:10:57:05 +0200] "GET /files/RPMS/rpm-libs-4.2.3-10.i386.rpm HTTP/1.1" 401 498 "-" "urlgrabber/2.9.0"
fedora.testnet - user [23/Sep/2004:10:57:08 +0200] "GET /files/RPMS/rpm-libs-4.2.3-10.i386.rpm HTTP/1.1" 206 4044 "-" "urlgrabber/2.9.0"
fedora.testnet - - [23/Sep/2004:11:07:45 +0200] "GET /files/RPMS/rpm-libs-4.2.3-10.i386.rpm HTTP/1.1" 401 498 "-" "urlgrabber/2.9.0"
fedora.testnet - user [23/Sep/2004:11:07:48 +0200] "GET /files/RPMS/rpm-libs-4.2.3-10.i386.rpm HTTP/1.1" 200 2231600 "-" "urlgrabber/2.9.0"
# 
--- snapp ---

Version-Release number of selected component (if applicable):
yum-2.1.3-1
yum HEAD CVS 1 h ago

How reproducible:
Everytime, see below.

Steps to Reproduce:
1. Run "yum update"
2. Have a look to the access_log of the http server were the rpm 
   files are from.
  
Actual results:
Yum downloads lots of rpm files 2 times. Together with bug #131095 
this is a total chaos in the log files...

Expected results:
Yum should download each file only one time per run, otherwise lots
of unnecessary traffic is done.
Comment 1 Bill Nottingham 2004-09-23 15:37:29 EDT
If I'm reading that right, all of the original requests are returning
401 (i.e., unauthorized)?
Comment 2 Bill Nottingham 2004-09-23 15:43:14 EDT
And the other requests are HTTP byte ranges.
Comment 3 Robert Scheck 2004-09-23 17:42:37 EDT
Yes, all of the original requests (two results per grep) are 
returning 401, but this is bug #131095 - the HTTP AUTH stuff isn't 
handled correct currently.

The main problem is, that every file is tried to get two times, see
for example 23/Sep/2004:10:57:11 and 23/Sep/2004:11:07:39 - so this 
occured at one yum run - and I also was able to get two downloads
per "yum update" run at repositories where yum didn't have to 
identify using HTTP AUTH.

23/Sep/2004:10:57:14 and 23/Sep/2004:11:07:57 for example are more
or less "ok", as long as I tolerate the problem of bug #131095...
Comment 4 Seth Vidal 2005-07-29 14:32:12 EDT
Is this still happening on recent releases?
Comment 5 Robert Scheck 2005-09-10 07:48:59 EDT
No, it seems to be fixed - at least - in yum-2.4.0-2, closing now.

Note You need to log in before you can comment on or make changes to this bug.