Bug 133381 - cat /proc/net/ip_conntrack produce kernel panic
cat /proc/net/ip_conntrack produce kernel panic
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: kernel (Show other bugs)
3.0
i686 Linux
medium Severity high
: ---
: ---
Assigned To: Thomas Graf
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-09-23 12:54 EDT by Levente Farkas
Modified: 2014-06-18 04:28 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-10-19 15:17:46 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Levente Farkas 2004-09-23 12:54:45 EDT
Description of problem:
cat /proc/net/ip_conntrack produce a kernel panic

Version-Release number of selected component (if applicable):
kernel 2.4.21-20.EL

How reproducible:
cat /proc/net/ip_conntrack
produce a kernel panic
but not always (unfortunately it's our production firewall) and we
inmediately reboot the server since it's not allowed to stop:-(


Steps to Reproduce:
1.
2.
3.
  
Actual results:
kernel panic after a few hundred lines

Expected results:
all lines are produced

Additional info:
it's a server with four ethernet card and a huge iptables firewall
(generated by shorewall). anyway the whole system working properly.
Comment 1 David Miller 2004-09-23 20:42:47 EDT
Without a OOPS trace there is no way I can possibly
debug this problem.
Comment 2 Craig 2004-10-01 23:11:42 EDT
I'm seeing kernel panics myself. If I run a script in cron that greps
/proc/net/ip_conntrack every few minutes, I get panics about once a week.

There's a bug entry at osdl.org:
http://bugme.osdl.org/show_bug.cgi?id=1764
And a mailing list posting to netfilter-devel:
http://lists.netfilter.org/pipermail/netfilter-devel/2004-April/015054.html

As far as I know these only apply to the 2.4.26 source, and the
function destroy_conntrack is different enough in my kernel (RH9
2.4.20-8) I don't know how to apply the patch.
Comment 3 Craig 2004-10-01 23:18:36 EDT
See also this netfilter bug entry:
https://bugzilla.netfilter.org/bugzilla/show_bug.cgi?id=131
Comment 4 Simon Matter 2005-08-12 06:05:00 EDT
I have just seen this panic on a RHEL3 U5 box, kernel-2.4.21-32.0.1.EL. I have
seen this back in the RH 7.x days but it's unfortunately it still happens with
the latest RHEL3 kernel.
Comment 5 Ernie Petrides 2005-11-28 21:58:35 EST
We're still waiting for the oops output.
Comment 6 Levente Farkas 2005-11-29 02:44:39 EST
we no longer use rhel 3 we update all of our server to rhel 4 and no longer get
the kernel panic. but just look at the above osdl bugzilla entry.
Comment 7 RHEL Product and Program Management 2007-10-19 15:17:46 EDT
This bug is filed against RHEL 3, which is in maintenance phase.
During the maintenance phase, only security errata and select mission
critical bug fixes will be released for enterprise products. Since
this bug does not meet that criteria, it is now being closed.
 
For more information of the RHEL errata support policy, please visit:
http://www.redhat.com/security/updates/errata/
 
If you feel this bug is indeed mission critical, please contact your
support representative. You may be asked to provide detailed
information on how this bug is affecting you.

Note You need to log in before you can comment on or make changes to this bug.