Bug 1333915 - Eclipse Neon (4.6.0): Unusable on dark Gtk+ themes like Adwaita:dark
Summary: Eclipse Neon (4.6.0): Unusable on dark Gtk+ themes like Adwaita:dark
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: eclipse
Version: 24
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Alexander Kurtakov
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-05-06 16:14 UTC by Christian Stadelmann
Modified: 2017-01-20 17:59 UTC (History)
7 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-01-20 11:12:54 UTC


Attachments (Terms of Use)
A screenshot of eclipse preferences window with dark Adwaita theme. (43.31 KB, image/png)
2016-05-06 16:27 UTC, Christian Stadelmann
no flags Details

Description Christian Stadelmann 2016-05-06 16:14:54 UTC
Version-Release number of selected component (if applicable):
eclipse-swt-4.6.0-0.5.git201604261105.fc24.x86_64

How reproducible:
Unclear, unable to test due to other bugs

Steps to Reproduce:
1. set a dark Gtk+ theme like Adwaita:dark, e.g. using gnome-tweak-tool
2. start eclipse

Actual results:
On migration dialog, light gray font appears on light gray background rendering any text unreadable. Contrast between background and foreground is too low.

Expected results:
Either eclipse is themed completely or it should ignore dark themes at all.

Additional info:
Same bug was present in LibreOffice ( https://bugzilla.redhat.com/show_bug.cgi?id=1287593, they chose to fix it ) and Firefox ( https://bugzilla.mozilla.org/show_bug.cgi?id=1268338 , they chose to ignore dark themes)

Comment 1 Christian Stadelmann 2016-05-06 16:27:05 UTC
Created attachment 1154704 [details]
A screenshot of eclipse preferences window with dark Adwaita theme.

After I managed to start eclipse, this issue is present not only for the migration window but also with other dialogs like the preferences dialog.

Comment 2 Alexander Kurtakov 2016-05-07 12:44:09 UTC
Please go to Windows/Preferences/General/Appearance and set the Theme combo to Dark. Eclipse has it's own styling framework which set's the prefer-dark-theme setting but currently Eclipse is not checking whether Gtk dark theme is used to flip eclipse.

Comment 3 Alexander Kurtakov 2017-01-20 11:12:54 UTC
Closing the bug. Please reopen if issue still happens for you with the instructions from previous comments.

Comment 4 Christian Stadelmann 2017-01-20 17:59:25 UTC
Thank you, works fine with latests eclipse version!


Note You need to log in before you can comment on or make changes to this bug.