Bug 1333987 - yumex-dnf fails and must exit
Summary: yumex-dnf fails and must exit
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: yumex-dnf
Version: 24
Hardware: x86_64
OS: Linux
unspecified
high
Target Milestone: ---
Assignee: Tim Lauridsen
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-05-06 23:38 UTC by Dan Beard
Modified: 2016-05-16 16:22 UTC (History)
2 users (show)

Fixed In Version: yumex-dnf-4.3.3-1.fc24
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-05-16 16:22:33 UTC
Type: Bug


Attachments (Terms of Use)

Description Dan Beard 2016-05-06 23:38:15 UTC
Description of problem: Yumex-dnf fails and requires exit


Version-Release number of selected component (if applicable):


How reproducible:Attempt to run yumex-dnf


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:
Terminal output as follows.

[dan@localhost ~]$ sudo yumex-dnf
[sudo] password for dan: 

(yumex-dnf:2024): Gtk-CRITICAL **: gtk_window_add_accel_group: assertion 'GTK_IS_WINDOW (window)' failed
18:27:33: EXCEPTION : g-dbus-error-quark: GDBus.Error:org.freedesktop.DBus.Error.NoReply: Message recipient disconnected from message bus without replying (4) 

(yumex-dnf:2024): Gtk-CRITICAL **: gtk_main_quit: assertion 'main_loops != NULL' failed
[dan@localhost ~]$

Comment 1 Tim Lauridsen 2016-05-09 07:56:57 UTC
Is this a one time issue or does it happens every time ?

Comment 2 Dan Beard 2016-05-09 10:49:49 UTC
Every time.   Yumex-dnf has now become useless.

Comment 3 Tim Lauridsen 2016-05-10 10:50:49 UTC
what version of yumex-dnf & dnfdaemon are you running ?

Comment 4 Dan Beard 2016-05-10 11:11:38 UTC
The latest version in the updates repo as of the date of the original report.  After the initial failure, I ran dnf-update from the terminal, and rebooted.   Problem still persists.   Yumex-dnf has been giving back-end failure reports via ABRT for a week or two before that.  BUt it would recover and run eventually.  I think those were automatically reported.

Not on that particular drive now, so I can't give you exact terminal output, but the vers. shouldn't be too hard to track down given the date.

Comment 5 Tim Lauridsen 2016-05-10 11:47:33 UTC
can you please try update to the dev version of yumex-dnf & dnfdaemon 

sudo dnf copr enable timlau/yumex-dnf
sudo dnf update yumex-dnf dnfdaemon --refresh

So see if it solves the issue

Comment 6 Dan Beard 2016-05-10 12:46:43 UTC
Ok.   Will do, but it will be late this afternoon/evening before I can get to it.   Gonna be stuck in meetings all day.

Comment 7 Dan Beard 2016-05-11 04:06:45 UTC
Evening, Tim.

SO far, so good.   Yumex-dnf failed as usual before I updated to your packages, and succeeded immediately afterward.  The system then updated correctly and Yumex-dnf exited cleanly.   Restarting yumex-dnf several times resulted in no further failures.

Looks like you've fixed the problem.   Nice work.   Thank you!

Comment 8 Fedora Update System 2016-05-11 09:02:10 UTC
dnfdaemon-0.3.15-1.fc24 yumex-dnf-4.3.3-1.fc24 has been submitted as an update to Fedora 24. https://bodhi.fedoraproject.org/updates/FEDORA-2016-aa868f02e4

Comment 9 Fedora Update System 2016-05-12 09:41:21 UTC
dnfdaemon-0.3.15-1.fc24, yumex-dnf-4.3.3-1.fc24 has been pushed to the Fedora 24 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-aa868f02e4

Comment 10 Fedora Update System 2016-05-16 16:22:14 UTC
dnfdaemon-0.3.15-1.fc24, yumex-dnf-4.3.3-1.fc24 has been pushed to the Fedora 24 stable repository. If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.