Bug 133415 - bootloader config didn't give multiboot option with existing FC2 installation
Summary: bootloader config didn't give multiboot option with existing FC2 installation
Status: CLOSED WONTFIX
Alias: None
Product: Fedora
Classification: Fedora
Component: anaconda   
(Show other bugs)
Version: 3
Hardware: i686
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Jeremy Katz
QA Contact: Mike McLean
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2004-09-23 20:29 UTC by anshul nigham
Modified: 2007-11-30 22:10 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-09-23 20:47:30 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description anshul nigham 2004-09-23 20:29:04 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; rv:1.7.3) Gecko/20040914
Firefox/0.10

Description of problem:
i had an existing installation of Fedora Core 2, and chose to install
FC3 test2 on a separate partition, with the intention of being able to
boot into either one (FC2 for normal work, FC3 for testing). anaconda
detected FC2 at first and gave the option to upgrade or install, and i
chose to install.

during the bootloader config, it did not add an option to boot into
the old FC2 installation (only the current option was given). i had to
modify grub.conf manually to add the option to boot from either
installation. which involved knowing where the kernel image was
located, etc. involved mounting the old /boot partition and copying
from the old grub.conf file. no data was lost, though.

considering the installer detects and offers multiboot options for
windows installations, i feel the same should happen for any linux
installation, especially a fedora one?

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Install FC2 with enough free unpartitioned free space to install FC3
2. Install FC3
3. Check bootloader configuration during installation of FC3.
    

Actual Results:  the bootloader only had one option - to boot into
fedora core 3 test 2.

Expected Results:  expected a multiboot option - boot into either
fedora core 3 test 2 or fedora core 2.

Additional info:

Comment 1 Jeremy Katz 2004-09-23 20:47:30 UTC
Dualbooting of Linux installations is far harder to reliably detect
than a Windows installation (to the point of being nearly impossible)
due to the variety of filesystems possible, etc.


Note You need to log in before you can comment on or make changes to this bug.