Bug 133421 - qla2200 drivers do not detect shared disks with RHEL3
qla2200 drivers do not detect shared disks with RHEL3
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: kernel (Show other bugs)
3.0
All Linux
medium Severity high
: ---
: ---
Assigned To: Tom Coughlan
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-09-23 17:20 EDT by Greg Marsden
Modified: 2007-11-30 17:07 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-12-22 08:36:34 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
scsi info (1.10 KB, text/plain)
2004-09-23 17:21 EDT, Greg Marsden
no flags Details
scsi info (1.10 KB, text/plain)
2004-09-23 17:21 EDT, Greg Marsden
no flags Details
/var/log/messages (25.37 KB, text/plain)
2004-09-23 17:24 EDT, Greg Marsden
no flags Details

  None (edit)
Description Greg Marsden 2004-09-23 17:20:42 EDT
qla2200 and addon/qla2200 drivers do not detect disks in HP VA array
when booted. 

Kernel version: RH3.0 (2.4.21-15.ELsmp), 

This did work with AS2.1
Comment 1 Greg Marsden 2004-09-23 17:21:36 EDT
Created attachment 104221 [details]
scsi info
Comment 2 Greg Marsden 2004-09-23 17:21:51 EDT
Created attachment 104222 [details]
scsi info
Comment 3 Greg Marsden 2004-09-23 17:23:27 EDT
Comment on attachment 104221 [details]
scsi info

<ignore>
Comment 4 Greg Marsden 2004-09-23 17:24:26 EDT
Created attachment 104223 [details]
/var/log/messages
Comment 5 Tom Coughlan 2004-09-24 06:35:42 EDT
You are running RHEL 3 U2, with driver version 6.07.02-RH2. Is there
am FC switch in the path?  What type?

Can you try U3? It has an updated QLogic driver.

Alternatively, in U2 we preserved the older driver as
qla2200_60600b11. It will be helpful to know if that works.
Comment 6 Greg Marsden 2004-09-24 13:14:29 EDT
I requested they try the QU3 kernel/driver yesterday after noticing
the large number of changes. Will let you know when we get results.

Did try the qla2200_60600b11 driver, but no luck with that one.
Comment 7 Tom Coughlan 2004-09-28 08:02:29 EDT
We are planning to update to Qlogic's 7.01.01 driver in U4.

So, in addition to testing the 7.00.03-RH1 driver in U3, I'd like to
make sure 7.01.01 works in this configuration.  Let me know the kernel
version if you would like me to provide a 7.01.01 driver for test.  
Comment 8 Greg Marsden 2004-09-28 20:15:21 EDT
I'll get an answer about the qu3 drivers soon. You're welcome to
provide the 7.01.01 driver against any EL3 kernel.

Thanks!
Comment 9 Greg Marsden 2004-09-30 16:44:03 EDT
QU3 (20.EL) still does not work, nor does the  qla2200_60702RH2 driver.

Here's an interesting thing I noticed this time around:
scsi(1): Topology - (F_Port), Host Loop address 0xffff
scsi-qla0-adapter-node=200000e08b0dfde7\;
scsi-qla0-adapter-port=210000e08b0dfde7\;
scsi-qla0-tgt-0-di-0-port=50060b000027b77c\;
qla2x00_detect num_hosts=0
scsi1 : QLogic QLA2200 PCI to Fibre Channel Host Adapter: bus 1 device
2 irq 20
        Firmware version:  2.02.06, Driver version 7.00.03-RH1

blk: queue e85f7c18, I/O limit 4294967295Mb (mask 0xffffffffffffffff)
  Vendor: HP        Model: A6189A            Rev: HP19
  Type:   Direct-Access                      ANSI SCSI revision: 03
blk: queue e8575418, I/O limit 4294967295Mb (mask 0xffffffffffffffff)
scsi(1:0:0:0): Enabled tagged queuing, queue depth 64.
Attached scsi disk sdb at scsi1, channel 0, id 0, lun 0
scsi(1) qla2x00_isr MBA_PORT_UPDATE ignored


** note it says attached scsi disk sdb

# cat /proc/partitions
major minor  #blocks  name     rio rmerge rsect ruse wio wmerge wsect
wuse running use aveq

   8     0   35564544 sda 27597 6124 268706 187500 8614 22140 246152
3079640 0 193580 3267130
   8     1   33455331 sda1 27546 5993 268282 187450 8614 22140 246152
3079640 0 193520 3267060
   8     2    2096482 sda2 13 41 168 30 0 0 0 0 0 30 30

** note this disk was not actually attached! and of course there are
other disks in the array which shoudl also be attached.

I believe the 7. driver is the same as that distributed by HP, and
will not work, but would be willing to try it out if you provide the
kernel.  The above observation may be more useful to track this down,
though.

Thanks,
Greg
Comment 10 Greg Marsden 2004-10-05 18:17:17 EDT
Qu3 + qla2200 driver (either) still did not work.

QU2 + qla2300 (card) + qla2300 (either) did not work

QU3 + qla2300 (card) + qla2300 (driver, stock) works. As a result,
they are upgrading this hardware to qla2300 to solve this issue.
Comment 11 Tom Coughlan 2004-12-22 08:36:34 EST
I am not sure why the qla2300 works and the qla2200 does not. There is
apparently a link-level incompatibility here with the FC switch or the
storage box. 

We did ship 7.01.01 in U4. One of the problems it fixes is to set FDMI
off by default. This may address the problem. 

I don't have this hardware to debug with, and since there is a
workaround for this customer, I'm going to close this BZ. 

Note You need to log in before you can comment on or make changes to this bug.