Bug 133435 - network comes up at 100 half duplex
network comes up at 100 half duplex
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
3
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Dave Jones
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-09-23 19:38 EDT by Jason
Modified: 2015-01-04 17:09 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-09-29 03:37:19 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jason 2004-09-23 19:38:09 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.3)
Gecko/20040910

Description of problem:
I am trying to do a network install of FC3T2.  When the system brings
up the network card it is using 100 MB half duplex.  The motherboard
is an Intel D850GB (with the latest BIOS), 256MB RAM, P4 1.4 Ghz.  The
network card is built into the motherboard.  It is a Intel
EtherExpress PRO 100.  Doing an install over a half duplex connection
takes 4 or 5 hours.  It should only take about an hour.  I am doing an
everything install.  The switch is programmed to use 100 Full duplex,
no AutoNegotiate.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.  Try to network install on an Intel D850GB
2.
3.
    

Actual Results:  the network card came up at 100 half duplex

Expected Results:  the network card should have come up at 100 full duplex

Additional info:
Comment 1 Jason 2004-10-04 23:20:44 EDT
Will this be fixed for FC3T3?
Comment 2 Jason 2004-10-14 19:55:52 EDT
I tried a http istall of FC3T3 and the network card still comes up as
100MB half duplex.  Please fix this before the final release.
Comment 3 Jason 2004-10-20 17:24:13 EDT
Is there something I can put on the kernel line that force the card 
to 100 full duplex?
Comment 4 Jason 2004-11-10 18:56:52 EST
Is anyone going to respond?  I cannot have 18 students installing FC3
over a 100MB half duplex connection.  As it is, a single everything
install says it will take 180 minutes (on a network with no other
traffic and the server on the same ethernet segment).
Comment 5 Terje Bless 2004-11-11 12:41:34 EST
Since the switch is set to forced 100/full, but the host is trying
to auto-negotiate the speed/duplex, the negotiation fails and the
host falls back to the 100/half setting that is mandated by the
relevant (IEEE802.3) standard. This creates the duplex mismatch that
makes network traffic slow.

Change the switch to auto-negotiate speed and duplex and the speed
should be within a reasonable margin of a fixed 100/full link.

100/half isn't usually a big problem, but a duplex-mismatch (one
end is full duplex, the other half) will slow down communications
considerably.

This is a (common) networking issue, so this bug should probably
be either RESOLVED INVALID/NOTABUG or recast as a RFE (for a way
to force speed/duplex in the installer boot).
Comment 6 Jason 2004-11-11 13:06:30 EST
Is there an easy way to tell if the card is using 100/fd or 100/hd
from the command line?

I will check out why the switches are configured to force 100/fd.

Thanks,

Jason
Comment 7 Terje Bless 2004-11-11 14:43:54 EST
On a running (installed) system you can use either "/sbin/mii-tool"
or "/sbin/ethtool eth0" to show the current state of a network device.

During install I would suspect these tools are not available.
Comment 8 Jason 2004-11-11 17:16:49 EST
The network port is now set to auto.  The speed is much better now. 
The question I have is, if the port was set to 100MB FD, then when the
driver tires to negotiate speed isn't the conversion something like:

Client: What speeds can you support?
Switch: 100MB-FD
Client: OK 100-FD it is.

Am I wrong?
Comment 9 Terje Bless 2004-11-12 03:32:56 EST
Unfortunately, yes. When you force the speed and duplex on the switch
you also disable all negotiation; so the conversation goes:

  Client: What speeds can you support?
  Switch:
  Client: OK I'll default to 100-HD as the standard requires.

The ultimate word on this is the IEEE 802.3 standards, and there are
some complexities involved not reflected in the above, but in practice
the conversation above is what you'll run up against.
Comment 10 Jason 2004-11-12 13:54:00 EST
Thank you for the information.  Please change this to a request for
enhancment.  Please add the ability to specify the network speed and
duplex settings on the kernel line.  I will also contact the switch
vendor and see if they can do anything.

Thanks,

Jason
Comment 11 Dave Jones 2005-07-15 15:59:03 EDT
An update has been released for Fedora Core 3 (kernel-2.6.12-1.1372_FC3) which
may contain a fix for your problem.   Please update to this new kernel, and
report whether or not it fixes your problem.

If you have updated to Fedora Core 4 since this bug was opened, and the problem
still occurs with the latest updates for that release, please change the version
field of this bug to 'fc4'.

Thank you.

Note You need to log in before you can comment on or make changes to this bug.