Bug 133440 - Bad Hadling of Lexmark Z600 Drivers
Bad Hadling of Lexmark Z600 Drivers
Status: CLOSED CANTFIX
Product: Fedora
Classification: Fedora
Component: redhat-config-printer (Show other bugs)
3
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Tim Waugh
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-09-23 20:08 EDT by Carlos Daniel Ruvalcaba Valenzuela
Modified: 2007-11-30 17:10 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-10-30 09:53:53 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Carlos Daniel Ruvalcaba Valenzuela 2004-09-23 20:08:47 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.2)
Gecko/20040809 Epiphany/1.3.8

Description of problem:
I have a lexmark z605 USB Printer that isn't supported by any cups or
gimp-print drivers, but lexmark offers linux cups drivers, the package
contains a pair of RPMs which include needed lirbaries for the driver
and the driver with cups ppd. 

After installing i load system-config-printer and configure the
printer, the printer is detected on USB (/dev/usb/lp0), but it won't
list the installed driver.

This may not seem like a bug or anything but for me is a big FLAW,
systems like Mandrake Control Center or Yast handles it fine, I have
to resort to the CUPS web interface to configure the printer, in this
case the driver and the printer are corrently detected without problems.

Version-Release number of selected component (if applicable):
system-config-printer-0.6.112-1

How reproducible:
Always

Steps to Reproduce:
1.Plug Lexmark Z600 Series Printer
2.Install Lexmark Z600 Series printer driver for CUPS for RedHat Linux.
3.Try to configure with system-config-printer
    

Actual Results:  Driver not available, not listed.

Expected Results:  The driver list (on Lexmark section) should have
the Lexmark z600 Series available as an option. Should detect the new
installed backend and printer driver from CUPS.

Additional info:

Printer: Lexmark Z605 USB Printer
Driver: Lexmark Z600 Series CUPS driver for RedHat Linux 9.0, v.1.0-1
CJLZ600LE-CUPS-1.0-1.TAR.gz
Comment 1 Tim Waugh 2004-09-24 03:41:24 EDT
The system-config-printer utility was only ever intended to work with
foomatic, so if it's not there in foomatic it won't be listed in
system-config-printer.

Did you try 'Import PPD...' from the Action menu?
Comment 2 Carlos Daniel Ruvalcaba Valenzuela 2004-09-24 20:47:08 EDT
Yes, i tried "Import PPD" but the Lexmark PPD was gzipped (the same as
all other ppd files on /usr/share/cups/model) and
system-config-printer dosen't handle them compressed, no problem, i
gunziped and tried again, the ppd was imported ok, tried adding the
printer and still the printer dosen't showed up not in lexmark, not in
others or generic.

I restarted the program one more time, and gived me this output:

No match for USB device:
  mfr "Lexmark "
  model "Z600 Series"
  desc "Lexmark Z600 Series"
  cmdset "CPDNPA001"
Please report this message in Bugzilla:
  https://bugzilla.redhat.com/bugzilla
Choose 'foomatic' as the component.


I tried anyways, and voila!, there it was, on Lexmark the "Z600
(PPD)", it whould be nice to import ppds without needed to restart the
program (maybe reopening the foomatic databases), handling gziped ppds
will be nice too, less hasle for newbies.

After adding the printer it asked me if i wished to print a test page,
ok print the test page, however there was an error, CUPS became
unresponsibe, i restared it (/etc/init.d/cups restart), deleted the
printer and tried again the whole thing, at the end the page was
sended but never printer.

The problem is that the Z600 series comes with a custom backend for
cups to comunicate to the printer and a custom rasterizer,
system-config-printer won't set the correct backend to comunicate, or
dosen't sets the correct rasterizer.
Comment 3 Tim Waugh 2004-12-03 12:04:27 EST
system-config-printer in rawhide now re-loads the foomatic database after
importing a PPD, and *ought* to behave a bit better with some third party
drivers.  It still won't know about extra backends though unfortunately.
Comment 4 John D. 2006-05-20 12:03:33 EDT
I have the same printer and followed the suggestions above.
The driver sees the printer because it wakes it up and then nothing happens. No 
blank paper or anything.
The printer is on a Win98 Print Serve serving several other printers. Windows 
apps can talk to the printer with no problem.

Thanks

John Dalton
engcon@engcon.org
Comment 5 Matthew Miller 2006-07-10 18:16:57 EDT
Fedora Core 3 is now maintained by the Fedora Legacy project for security
updates only. If this problem is a security issue, please reopen and
reassign to the Fedora Legacy product. If it is not a security issue and
hasn't been resolved in the current FC5 updates or in the FC6 test
release, reopen and change the version to match.

Thank you!
Comment 6 John Thacker 2006-10-30 09:53:53 EST
Closing per lack of response to previous request for information.
Note that FC3 and FC4 are supported by Fedora Legacy for security
fixes only.  Please install a still supported version and retest.  If
it still occurs on FC5 or FC6, please reopen and assign to the correct
version.  Otherwise, if this a security issue, please change the
product to Fedora Legacy.  Thanks, and we are sorry that we did not
get to this bug earlier.

Note You need to log in before you can comment on or make changes to this bug.