Bug 133466 - iostat leaks file descriptors
iostat leaks file descriptors
Status: CLOSED DUPLICATE of bug 131878
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: sysstat (Show other bugs)
3.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Charlie Bennett
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-09-24 04:03 EDT by Göran Uddeborg
Modified: 2007-11-30 17:07 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 14:05:50 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Göran Uddeborg 2004-09-24 04:03:52 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux x86_64; en-US; rv:1.4.3)
Gecko/20040803

Description of problem:
Leaving "iostat X" running for a long time finally ends with an error
message about lack of file descriptors.

Version-Release number of selected component (if applicable):
sysstat-4.0.7-4.EL3.3

How reproducible:
Always

Steps to Reproduce:
1. Run "iostat 1"
2. Go for lunch and come back

Actual Results:  Iostat has died with a "Too many open files" message

Expected Results:  Iostat should keep on writing a message each second
about I/O statistics.

Additional info:

Doing an "lsof -p NNN" on the running iostat reveals it opens
/proc/stat for each loop, but never closes it.

Limiting the number of file descriptors allowed (ulimit -n X/limit
descriptors X) is a faster way to trigger the problem.
Comment 1 Göran Uddeborg 2004-09-24 08:14:11 EDT
Hmm, just found this was already reported.  I must have made some
mistake when I searched for it before reporting.

*** This bug has been marked as a duplicate of 131878 ***
Comment 2 Red Hat Bugzilla 2006-02-21 14:05:50 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.