Bug 133469 - Spamassassin 3.0.0 - fix for SPEC file (krb5 compat)
Spamassassin 3.0.0 - fix for SPEC file (krb5 compat)
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: spamassassin (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Chip Turner
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-09-24 04:41 EDT by Milan Kerslager
Modified: 2007-11-30 17:10 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-09-24 05:35:49 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Milan Kerslager 2004-09-24 04:41:17 EDT
Current devel package for Spamassassin 3.0.0 from devel tree has one 
more trouble (for older systems) with this line:

Requires: perl(:MODULE_COMPAT

Please add condition for this line to allow to compile on older 
systems like RHEL3 or older FC releases:

%if !%{krb5backcompat}
Requires: perl(:MODULE_COMPAT_....
%endif

The condition should be better to reflect current perl version so you 
may have better solution. This is only simplest...
Comment 1 Warren Togami 2004-09-24 05:35:49 EDT
Sorry no.  All newer distributions follow this convention, and krb5
back compat is not an accurate condition to decide if this valid for
the target distribution.

http://www.fedora.us/pkglists/9/stable/perl-forward-compat-5.8.0-0.fdr.2.src.rpm.html
Either remove that line for your rebuild, or use adapt
perl-forward-compat for your distribution.
Comment 2 Milan Kerslager 2004-09-29 15:26:46 EDT
Thank you for suggesting better fix.

Note You need to log in before you can comment on or make changes to this bug.