Bug 1335113 - Cannot paste text as command in GNOME3
Summary: Cannot paste text as command in GNOME3
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: gnome-shell
Version: 7.3
Hardware: x86_64
OS: Linux
unspecified
unspecified
Target Milestone: rc
: ---
Assignee: Florian Müllner
QA Contact: Desktop QE
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-05-11 11:54 UTC by Pavlin Georgiev
Modified: 2016-09-20 13:16 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-09-20 13:16:06 UTC
Target Upstream Version:


Attachments (Terms of Use)
Screenshots from GNOME (1.69 MB, application/zip)
2016-05-11 11:54 UTC, Pavlin Georgiev
no flags Details


Links
System ID Private Priority Status Summary Last Updated
GNOME Bugzilla 766325 0 None None None 2016-05-12 13:46:37 UTC
GNOME Bugzilla 766326 0 None None None 2016-05-12 13:47:00 UTC

Description Pavlin Georgiev 2016-05-11 11:54:36 UTC
Created attachment 1156101 [details]
Screenshots from GNOME

Description of problem:
When I am trying to execute a command in GNOME GUI by pressing ALT+F2,
I am not able to paste any text under these conditions:
1) the keyboard layout is US EN and the Caps lock in ON.
2) the keyboard layout is RU (Phonetic, Winkeys)

Version-Release number of selected component (if applicable):
RHEL 7.3 Workstation on x86_64 with:
gnome-session-3.14.0-5.el7.x86_64


How reproducible:
Always

Steps to Reproduce:
1. Copy text from a text editor (gedit or kate) or from the console
2. Turn on Caps lock
3. Press ALT+F2
4. Press CTRL+V
5. The bug appears
6. Turn off caps lock
7. Add Russian keyboard layout, for example Phonetic with Winkeys
8. Repeat steps 1,3,4
9. The bug appears
10. Set the keyboard layout to US English.

Actual results:
Cannot paste any text as a command.

Expected results:
Paste the copied text as a command.

Comment 1 Pavlin Georgiev 2016-05-11 11:55:57 UTC
I am not sure about the component's name which is responsible for accepting text as a command. I mean after pressing ALT+F2.

Comment 2 Pavlin Georgiev 2016-05-11 11:59:16 UTC
Version of GNOME shell:
gnome-shell-3.14.4-39.el7.x86_64

Comment 4 Florian Müllner 2016-05-12 13:46:38 UTC
(In reply to Pavlin Georgiev from comment #0)
> Steps to Reproduce:
> 1. Copy text from a text editor (gedit or kate) or from the console
> 2. Turn on Caps lock
> 3. Press ALT+F2
> 4. Press CTRL+V

That's because the shortcut is ctrl+v, not ctrl+V.

Comment 5 Pavlin Georgiev 2016-09-20 13:16:06 UTC
This is the expected behaviour, not a bug.


Note You need to log in before you can comment on or make changes to this bug.