Bug 133538 - Upgrading RPM in Red Hat 6.2
Upgrading RPM in Red Hat 6.2
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: rpm (Show other bugs)
rawhide
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Jeff Johnson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-09-24 13:42 EDT by Gamaiel Zavala
Modified: 2007-11-30 17:10 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-10-05 08:18:28 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Output of rpm -Uvv... (11.28 KB, text/plain)
2004-10-01 11:48 EDT, Gamaiel Zavala
no flags Details

  None (edit)
Description Gamaiel Zavala 2004-09-24 13:42:07 EDT
Description of problem:
I have followed various directions on the internet to upgrade RPM.
Each has resulted in failure with various rpm functions resulting in
segfaults and core dumps. I have since reinstalled Red Hat 6.2 after
completely destroying RPM functionality, so I am starting from a clean
installation. I am interested in getting the latest SSH components
working and hardening the system as much as possible through updates,
patches etc. A step-by-step walkthrough would be much appreciated.

How reproducible:
always

Steps to Reproduce:
1. Upgrade to db3-3
2. Upgrade to RPM-4
3. Begin updating other packages
  
Actual results:
Segfaults when using various RPM functions, initially on queries only
but worsens to the point of non-functionality as packages are added.

Expected results:
Normal functionality.

Additional info:
Locked into RH6.2 for legacy software.
Comment 1 Jeff Johnson 2004-09-26 13:21:00 EDT
The global steps are as follows:

1) Save a copy of you rpmdb right now just in case:
    rpm --rebuilddb
    cd /var/lib
    tar czvf /tmp/rpmdb.tar.gz rpm

2) Upgrade to rpm-3.0.5 (from ftp.rpm.org) if not already
    running that. Repeat step 1) if you upgrade.

3) Download rpm-4.0.4 packages built for RHL 6.2 from ftp.rpm.org
    rpm
    rpm-devel
    rpm-build
    rpm-python
    popt
Install all of those packages in a single command.

4) Verify that rpm -qa is functional, then convert from
db1 -> db3 format by doing
    rpm --rebuilddb -vv

Poke this bug out of NEEDINFO -> ASSIGNED if you need help.

Comment 2 Gamaiel Zavala 2004-09-27 13:34:31 EDT
On #3 I get:
error: Failed Dependencies
libbz2.so.1             rpm-4.0.4-7x.i386
libc.so.6(GLIBC_2.2)    rpm-4.0.4-7x.i386
libc.so.6(GLIBC_2.2.3)  rpm-4.0.4-7x.i386
libbz2.so.1             rpm-build-4.0.4-7x.i386
libbz2.so.1             rpm-python-4.0.4-7x.i386
Comment 3 Jeff Johnson 2004-09-28 08:03:34 EDT
Those are package from RHL 7x, you want packages for RHL 6x.

Comment 4 Gamaiel Zavala 2004-09-29 13:29:06 EDT
Ah yes, some things are obvious only in hindsight. So I've upgraded
rpm using to 3.05 using 'rpm -Fvh rpm-3.0.5-7.6x.i386.rpm', rebuilt
the db and and tarred /var/lib/rpm. I have now downloaded the correct
packages (6x) and tried to install them using 'rpm -ivh
rpm-4.0.4-6x.i386.rpm rpm-devel-4.0.4-6x.i386.rpm \
rpm-build-4.0.4-6x.i386.rpm rpm-python-4.0.4-6x.i386.rpm
popt-1.6.4-6x.i386.rpm'. I get close to 70 errors like this: "file
/bin/rpm from install of rpm-4.0.4-6x conflicts with file from package
rpm-3.0.5-7.6x". I'm hesitant to flag freshen since that's how I broke
rpm last time. Any suggestions?
Comment 5 Jeff Johnson 2004-09-29 20:26:02 EDT
Hmmm, check the size of the rpm-4.0.4-6x packages please.
There was a build screwup that resulted in empty package payloads.

Try ftp://people.redhat.com/jbj/rpm-4.0.4-6x/*.i386.rpm
packages instead.

Apologies for not recalling earlier, been awhile.
Comment 6 Gamaiel Zavala 2004-09-30 11:32:02 EDT
Yes, the 6x packages from rpm.org were very small in size. I've
downloaded the new packages above and get the same conflict messages
as before.
Comment 7 Jeff Johnson 2004-09-30 20:40:48 EDT
Hmmm, can you attach the output here? Look particularly for the
1st msg, as file conflicts often are derivative on some other
problem, like pkg already installed.
Comment 8 Gamaiel Zavala 2004-10-01 11:48:17 EDT
Created attachment 104633 [details]
Output of rpm -Uvv...
Comment 9 Gamaiel Zavala 2004-10-01 11:49:35 EDT
I ran the command provided via email: 'rpm -Uvv {rpm,popt}-*.i386.rpm
>& /tmp/output.log', the results are attached above.
Comment 10 Jeff Johnson 2004-10-01 19:54:26 EDT
OK, you need to upgrade *all* the packages
in the same command:
  rpm -Uvh rpm-4.0.4-*.rpm rpm-devel-4.0.4-*.rpm rpm-build-4.0.4-*.rpm ...

All the packages in one command.

Verify with
    rpm -qa

If that "works", then do
    rpm --rebuilddb -vv
to convert db1 -> db3 format.
Comment 11 Gamaiel Zavala 2004-10-04 12:36:23 EDT
That worked! Thanks so much for all of your help.

Note You need to log in before you can comment on or make changes to this bug.