Bugzilla (bugzilla.redhat.com) will be under maintenance for infrastructure upgrades and will not be available on July 31st between 12:30 AM - 05:30 AM UTC. We appreciate your understanding and patience. You can follow status.redhat.com for details.
Bug 1335380 - Missing efibootmgr package in rhev-hypervisor-ng for EFI support
Summary: Missing efibootmgr package in rhev-hypervisor-ng for EFI support
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: redhat-release-rhev-hypervisor
Version: 4.0.0
Hardware: Unspecified
OS: Unspecified
high
high
Target Milestone: ovirt-4.0.0-rc
: 4.0.0
Assignee: Fabian Deutsch
QA Contact: Ying Cui
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-05-12 06:54 UTC by Ying Cui
Modified: 2016-08-23 21:12 UTC (History)
10 users (show)

Fixed In Version: rhev-hypervisor7-ng-4.0-20160603.0
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-08-23 21:12:02 UTC
oVirt Team: Node
Target Upstream Version:
ycui: testing_plan_complete+


Attachments (Terms of Use)
ngm.ks (163 bytes, text/plain)
2016-05-12 06:56 UTC, Ying Cui
no flags Details


Links
System ID Private Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2016:1688 0 normal SHIPPED_LIVE redhat-release-virtualization-host bug fix and enhancement update for RHV 4.0 2016-08-24 00:37:04 UTC

Description Ying Cui 2016-05-12 06:54:15 UTC
Description of problem:
Missing efibootmgr package in rhev-hypervisor-ng.

Version-Release number of selected component (if applicable):
rhev-hypervisor7-ng-20160506.0.el7
imgbased-0.6-0.1.el7ev.noarch

How reproducible:
100%

Steps to Reproduce:
1. Anaconda GUI installed rhev-hypervisor7-ng-3.6-20160506.0.el7 successful. Attachment: ngm.ks
2. Drop to shell
# rpm -qa dracut-config-generic efibootmgr grub2-efi memtest86+ syslinux
syslinux-4.05-12.el7.x86_64
memtest86+-4.20-14.el7.x86_64
grub2-efi-2.02-0.34.el7_2.x86_64
dracut-config-generic-033-360.el7_2.x86_64

Actual results:
Missing the efibootmgr in rhev-hypervisor-ng for EFI support.

Expected results:
efibootmgr rpm should be built into rhev-hypervisor-ng build.

Comment 1 Ying Cui 2016-05-12 06:56:23 UTC
Created attachment 1156451 [details]
ngm.ks

Comment 2 Fabian Deutsch 2016-05-31 09:34:43 UTC
This should be fixed in d/s by including @anaconda-tools

Comment 4 Frank DeLorey 2016-06-06 10:23:14 UTC
Does this indicate that a RHEV-H host running in EFI mode cannot change its kernel parameters?

Comment 5 Fabian Deutsch 2016-06-06 18:43:55 UTC
No - I am not aware of such a limitation.

The funcationality will be as on RHEL, but a path (to grub.cfg) might be different.

Comment 6 Ying Cui 2016-06-12 06:07:12 UTC
VERIFIED on build rhev-hypervisor7-ng-4.0-20160608.0(redhat-release-rhev-hypervisor-4.0-0.6.el7)

# rpm -qa imgbased
imgbased-0.7.0-0.1.el7ev.noarch

# rpm -qa dracut-config-generic efibootmgr grub2-efi memtest86+ syslinux
memtest86+-4.20-14.el7.x86_64
grub2-efi-2.02-0.34.el7_2.x86_64
efibootmgr-0.8.0-7.el7.x86_64
syslinux-4.05-12.el7.x86_64
dracut-config-generic-033-360.el7_2.x86_64

Result:
efibootmgr rpm is built into rhev-hypervisor-ng build.

Comment 8 errata-xmlrpc 2016-08-23 21:12:02 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2016-1688.html


Note You need to log in before you can comment on or make changes to this bug.