Bug 133555 - Strings returns "Value too large for defined data type" on >2G files
Summary: Strings returns "Value too large for defined data type" on >2G files
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: binutils   
(Show other bugs)
Version: 2
Hardware: i686
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Jakub Jelinek
QA Contact:
URL:
Whiteboard:
Keywords:
: 138494 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2004-09-24 19:31 UTC by M Shannon
Modified: 2007-11-30 22:10 UTC (History)
2 users (show)

Fixed In Version: binutils-2.15.92.0.2-3
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-10-12 11:57:27 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description M Shannon 2004-09-24 19:31:15 UTC
Description of problem:

strings against a >2G file produces.

"Value too large for defined data type"


Version-Release number of selected component (if applicable):

binutils-2.15.90.0.3-5.i386.rpm   

How reproducible:

/usr/sbin/strings "filename" where filename is a >2G file.

Steps to Reproduce:
1.
2.
3.
  
Actual results:

"Value too large for defined data type"

Expected results:

strings output

Additional info:


I'm guessing a config flag fell out of the spec file...

Comment 1 M Shannon 2004-09-24 20:06:01 UTC
added -D_FILE_OFFSET_BITS=64 -D_LARGEFILE64_SOURCE=1

To the Makefile.in INCLUDES in the binutils directory.

Works.

Comment 2 Jakub Jelinek 2004-10-12 11:57:27 UTC
I fixed this back in 2001, but a patch added last year apparently
broke it again.

Comment 3 Jakub Jelinek 2004-11-09 16:33:33 UTC
*** Bug 138494 has been marked as a duplicate of this bug. ***


Note You need to log in before you can comment on or make changes to this bug.