Bug 133596 - System-config-soundcard play test sound should set volume
System-config-soundcard play test sound should set volume
Status: CLOSED DUPLICATE of bug 127863
Product: Fedora
Classification: Fedora
Component: system-config-soundcard (Show other bugs)
3
All Linux
medium Severity medium
: ---
: ---
Assigned To: Bastien Nocera
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-09-24 20:21 EDT by Tom Mitchell
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 14:05:52 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Tom Mitchell 2004-09-24 20:21:33 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.3)
Gecko/20040922

Description of problem:
System-config-soundcard play test sound should set volume.

On a clean install of FC3T2 System-config-soundcard
lets me play a test sound but the volume is zero
so it sounds as if the test failed.

The "play test sound buton" step should notice zero volume settings
and set them to the 50%-75% range and or present a slider.  

A late in the game safe option might be to add some text to the play
sound box and have a user run "aumix" in a terminal window to check
levels if they hear nothing.

While strictly this is an RFE enough people have trouble with
FCn sound cards that some solution should be considered.

Perhaps there is a more logical place to address this
but to me this 'sounds right'.  Feel free to punt this to 
an alternative solution....



Version-Release number of selected component (if applicable):
system-config-soundcard-1.2.9-1

How reproducible:
Always

Steps to Reproduce:
1. New system install
2. run system-config-soundcard  (soundcard detection)
3. click on play test sound and listen.
    I get silence on a fresh install.

Actual Results:  Silence.

Expected Results:  Expect to hear a nifty right left stereo sound.

Additional info:  Thanks.
Comment 1 Michael Schwendt 2004-09-26 06:18:49 EDT
It does set the PCM volume with /usr/bin/amixer, see
/usr/share/system-config-soundcard/soundcardBackend.py

But it uses /usr/bin/play to play the test sound on OSS device
/dev/dsp instead of ALSA, so maybe ALSA->OSS driver routing is the
culprit again.
Comment 2 Bastien Nocera 2004-09-30 19:58:59 EDT
Michael, 1.2.9-1 uses aplay to play the sound sample, not "play". If
I'm wrong, feel free to file a bug :)

Tom, could you check, by launching gnome-volume-control which tracks
(in the ALSA tab for your card, if there is more than one) you need to
unmute and set the volume for, in order to get sound on your machine?
Comment 3 Michael Schwendt 2004-10-02 08:24:14 EDT
Sorry. Bug report says "clean install of FC3T2", which would be
system-config-soundcard-1.2.8-1 and not 1.2.9-1.
Comment 4 Tom Mitchell 2004-10-02 10:28:40 EDT
Fresh test last night.
Clean install of FC3T2 followed promptly by a full rawhide up2date.
(No previous OS cruft ...)

This resulted in system-config-soundcard-1.2.10-1
and no modification to any config files beyond firstboot stuff.

Ran system-config-soundcard an it detected the card OK but the 
volume was zero and no sound was heard.

Next aumix was run and only two sliders were non zero, Vol and  Pcm
and system-config-soundcard was silent.
I adjusted Pcm2 to a volume that matched levels of  Vol and  Pcm and
reran  system-config-soundcard. Sound was fine.

Next looking at gnome-volume-control I see two tabs.
The first (OSS mixer) shows me PCM-2 which tracks Pcm2 on 
aumix.  The second tab, Alsa Mixer does not have a Pcm2 slider
however the slider labeled headphone tracks the Pcm2 slider
of aumix.

When sound is OK the interesting parts of "amixer" output are:
Simple mixer control 'Master',0
  Capabilities: pvolume pswitch pswitch-joined
  Playback channels: Front Left - Front Right
  Limits: Playback 0 - 31
  Front Left: Playback 23 [74%] [on]
  Front Right: Playback 23 [74%] [on]
....
Simple mixer control 'Headphone',0
  Capabilities: pvolume pswitch pswitch-joined
  Playback channels: Front Left - Front Right
  Limits: Playback 0 - 31
  Front Left: Playback 23 [74%] [on]
  Front Right: Playback 23 [74%] [on]
....
Simple mixer control 'PCM',0
  Capabilities: pvolume pswitch pswitch-joined
  Playback channels: Front Left - Front Right
  Limits: Playback 0 - 31
  Front Left: Playback 23 [74%] [on]
  Front Right: Playback 23 [74%] [on]

Should I push back to system-config-soundcard-1.2.8-1?
Which is expected to be included in FC3...

Thanks
mitch
Comment 5 Bastien Nocera 2004-10-03 07:38:33 EDT
This is already fixed in CVS. We now also try to set the volume for
"PCM-2". Package should be available soon via rawhide.

*** This bug has been marked as a duplicate of 127863 ***
Comment 6 Red Hat Bugzilla 2006-02-21 14:05:52 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.